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Chapter 1 - Fundamental Skills
Microsoft® Excel® is a tool that can be used in virtually all careers and is valuable in both professional and personal settings. Whether you need to keep track of medications in inventory for a hospital or create a financial plan for your retirement, Excel enables you to do these activities efficiently and accurately. This chapter introduces the fundamental skills necessary to get you started in using Excel. You will find that just a few skills can make you very productive in a short period of time.
Adapted from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Examine the value of using Excel to make decisions.
- Learn how to start Excel.
- Become familiar with the Excel workbook.
- Understand how to navigate worksheets.
- Examine the Excel Ribbon.
- Examine the right-click menu options.
- Learn how to save workbooks.
- Examine the Status Bar.
- Become familiar with the features in the Excel Help window.
Microsoft® Office contains a variety of tools that help people accomplish many personal and professional objectives. Microsoft Excel is perhaps the most versatile and widely used of all the Office applications. No matter which career path you choose, you will likely need to use Excel to accomplish your professional objectives, some of which may occur daily. This chapter provides an overview of the Excel application along with an orientation for accessing the commands and features of an Excel workbook.
Taking a very simple view, Excel is a tool that allows you to enter quantitative data into an electronic spreadsheet to apply one or many mathematical computations. These computations ultimately convert that quantitative data into information. The information produced in Excel can be used to make decisions in both professional and personal contexts. For example, employees can use Excel to determine how much inventory to buy for a clothing retailer, how much medication to administer to a patient, or how much money to spend to stay within a budget. With respect to personal decisions, you can use Excel to determine how much money you can spend on a house, how much you can spend on car lease payments, or how much you need to save to reach your retirement goals. We will demonstrate how you can use Excel to make these decisions and many more throughout this text.
Figure 1.1 shows a completed Excel worksheet that will be constructed in this chapter. The information shown in this worksheet is top-line sales data for a hypothetical merchandise retail company. The worksheet data can help this retailer determine the number of salespeople needed for each month, how much inventory is needed to satisfy sales, and what types of products should be purchased.
Once Excel is started, a blank workbook will open on your screen. A workbook is an Excel file that contains one or more worksheets (sometimes referred to as spreadsheets). Excel will assign a file name to the workbook, such as Book1, Book2, Book3, and so on, depending on how many new workbooks are opened. Figure 1.2 shows a blank workbook after starting Excel. Take some time to familiarize yourself with this screen. Your screen may be slightly different based on the version you’re using.
Your workbook should already be maximized (or shown at full size) once Excel is started, as shown in Figure 1.2. However, if your screen looks like Figure 1.3 after starting Excel, you should click the Maximize button, as shown in the figure.
Data are entered and managed in an Excel worksheet. The worksheet contains several rectangles called cells for entering numeric and nonnumeric data. Each cell in an Excel worksheet contains an address, which is defined by a column letter followed by a row number. For example, the cell that is currently activated in Figure 1.3 is A1. This would be referred to as cell location A1 or cell reference A1. The following steps explain how you can navigate in an Excel worksheet:
Note: Your highlighted column letter and row number may be different than figure shown.
This is referred to as a cell range and is documented as follows: A1:D5. Any two cell locations separated by a colon are known as a cell range. The first cell is the top left corner of the range, and the second cell is the lower right corner of the range.
Keyboard Shortcuts
Basic Worksheet Navigation
- Use the arrow keys on your keyboard to activate cells on the worksheet.
- Hold the SHIFT key and press the arrow keys on your keyboard to highlight a range of cells in a worksheet.
- Hold the CTRL key while pressing the PAGE DOWN or PAGE UP keys to open other worksheets in a workbook.
Excel’s features and commands are found in the Ribbon, which is the upper area of the Excel screen that contains several tabs running across the top. Each tab provides access to a different set of Excel commands. Figure 1.6 shows the commands available in the Home tab of the Ribbon. Table 1.1 “Command Overview for Each Tab of the Ribbon” provides an overview of the commands that are found in each tab of the Ribbon.
Table 1.1 Command Overview for Each Tab of the Ribbon
Tab Name | Description of Commands |
File | Also known as the Backstage view of the Excel workbook. Contains all commands for opening, closing, saving, and creating new Excel workbooks. Includes print commands, document properties, e-mailing options, and help features. The default settings and options are also found in this tab. |
Home | Contains the most frequently used Excel commands. Formatting commands are found in this tab along with commands for cutting, copying, pasting, and for inserting and deleting rows and columns. |
Insert | Used to insert objects such as charts, pictures, shapes, PivotTables, Internet links, symbols, or text boxes. |
Page Layout | Contains commands used to prepare a worksheet for printing. Also includes commands used to show and print the gridlines on a worksheet. |
Formulas | Includes commands for adding mathematical functions to a worksheet. Also contains tools for auditing mathematical formulas. |
Data | Used when working with external data sources such as Microsoft® Access®, text files, or the Internet. Also contains sorting commands and access to scenario tools. |
Review | Includes Spelling and Track Changes features. Also contains protection features to password protect worksheets or workbooks. |
View | Used to adjust the visual appearance of a workbook. Common commands include the Zoom and Page Layout view. |
The Ribbon shown in Figure 1.6 is full, or maximized. The benefit of having a full Ribbon is that the commands are always visible while you are developing a worksheet. However, depending on the screen dimensions of your computer, you may find that the Ribbon takes up too much vertical space on your worksheet. If this is the case, you can minimize the Ribbon by clicking the button shown in Figure 1.6. When minimized, the Ribbon will show only the tabs and not the command buttons. When you click on a tab, the command buttons will appear until you select a command or click anywhere on your worksheet.
Keyboard Shortcuts
Minimizing or Maximizing the Ribbon
- Hold down the CTRL key and press the F1 key.
- Hold down the CTRL key and press the F1 key again to maximize the Ribbon.
The Quick Access Toolbar is found at the upper left side of the Excel screen above the Ribbon, as shown in Figure 1.7. This area provides access to the most frequently used commands, such as Save and Undo. You also can customize the Quick Access Toolbar by adding commands that you use on a regular basis. By placing these commands in the Quick Access Toolbar, you do not have to navigate through the Ribbon to find them. To customize the Quick Access Toolbar, click the down arrow as shown in Figure 1.7. This will open a menu of commands that you can add to the Quick Access Toolbar. If you do not see the command you are looking for on the list, select the More Commands option.
In addition to the Ribbon and Quick Access Toolbar, you can also access commands by right clicking anywhere on the worksheet. Figure 1.8 shows an example of the commands available in the right-click menu.
The File tab is also known as the Backstage view of the workbook. It contains a variety of features and commands related to the workbook that is currently open, new workbooks, or workbooks stored in other locations on your computer or network. Figure 1.9 shows the options available in the File tab or Backstage view. To leave the Backstage view and return to the worksheet, click the arrow in the upper left-hand corner as shown below.
Included in the File tab are the default settings for the Excel application that can be accessed and modified by clicking the Options button. Figure 1.10 shows the Excel Options window, which gives you access to settings such as the default font style, font size, and the number of worksheets that appear in new workbooks.
Once you create a new workbook, you will need to change the file name and choose a location on your computer or network to save that file. It is important to remember where you save this workbook on your computer or network as you will be using this file in the Section 1.2 “Entering, Editing, and Managing Data” to construct the workbook shown in Figure 1.1. The process of saving can be different with different versions of Excel. Please be sure you follow the steps for the version of Excel you are using. The following steps explain how to save a new workbook and assign it a file name.
Keyboard Shortcuts
Save As
- Press the F12 key and use the tab and arrow keys to navigate around the Save As dialog box. Use the ENTER key to make a selection.
- Or press the ALT key on your keyboard. You will see letters and numbers, called Key Tips, appear on the Ribbon. Press the F key on your keyboard for the File tab and then the A key. This will open the Save As dialog box.
Skill Refresher
Saving Workbooks (Save As)
- Click the File tab on the Ribbon.
- Click the Save As option.
- Select a location on your PC.
- Click in the File name box and type a new file name if needed.
- Click the down arrow next to the “Save as type” box and select the appropriate file type if needed.
- Click the Save button.
The Status Bar is located below the worksheet tabs on the Excel screen (see Figure 1.13). It displays a variety of information, such as the status of certain keys on your keyboard (e.g., CAPS LOCK), the available views for a workbook, the magnification of the screen, and mathematical functions that can be performed when data are highlighted on a worksheet. You can customize the Status Bar as follows:
The Help feature provides extensive information about the Excel application. Although some of this information may be stored on your computer, the Help window will automatically connect to the Internet, if you have a live connection, to provide you with resources that can answer most of your questions. You can open the Excel Help window by clicking the question mark in the upper right area of the screen or ribbon. With newer versions of Excel, use the query box to enter your question and select from helpful option links or select the question mark from the dropdown list to launch Excel Help windows.
Keyboard Shortcuts
Excel Help
- Press the F1 key on your keyboard.
Key Takeaways
- Excel is a powerful tool for processing data for the purposes of making decisions.
- You can find Excel commands throughout the tabs in the Ribbon.
- You can customize the Quick Access Toolbar by adding commands you frequently use.
- You can add or remove the information that is displayed on the Status Bar.
- The Help window provides you with extensive information about Excel.
Adapted by Barbara Lave from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Understand how to enter data into a worksheet.
- Examine how to edit data in a worksheet.
- Examine how Auto Fill is used when entering data.
- Understand how to delete data from a worksheet and use the Undo command.
- Examine how to adjust column widths and row heights in a worksheet.
- Understand how to hide columns and rows in a worksheet.
- Examine how to insert columns and rows into a worksheet.
- Understand how to delete columns and rows from a worksheet.
- Learn how to move data to different locations in a worksheet.
In this section, we will begin the development of the workbook shown in Figure 1.1. The skills covered in this section are typically used in the early stages of developing one or more worksheets in a workbook.
You will begin building the workbook shown in Figure 1.1 by manually entering data into the worksheet. The following steps explain how the column headings in Row 2 are typed into the worksheet:
Figure 1.15 shows how your worksheet should appear after you have typed the column headings into Row 2. Notice that the word Price in cell location C2 is not visible. This is because the column is too narrow to fit the entry you typed. We will examine formatting techniques to correct this problem in the next section.
Integrity Check
Column Headings
It is critical to include column headings that accurately describe the data in each column of a worksheet. In professional environments, you will likely be sharing Excel workbooks with coworkers. Good column headings reduce the chance of someone misinterpreting the data contained in a worksheet, which could lead to costly errors depending on your career.
Why?
Avoid Formatting Symbols When Entering Numbers
When typing numbers into an Excel worksheet, it is best to avoid adding any formatting symbols such as dollar signs and commas. Although Excel allows you to add these symbols while typing numbers, it slows down the process of entering data. It is more efficient to use Excel’s formatting features to add these symbols to numbers after you type them into a worksheet.
Integrity Check
Data Entry
It is very important to proofread your worksheet carefully, especially when you have entered numbers. Transposing numbers when entering data manually into a worksheet is a common error. For example, the number 563 could be transposed to 536. Such errors can seriously compromise the integrity of your workbook.
Integrity Check
Figure 1.16 shows how your worksheet should appear after entering the data. Check your numbers carefully to make sure they are accurately entered into the worksheet.
Data that has been entered in a cell can be changed by double clicking the cell location or using the Formula Bar. You may have noticed that as you were typing data into a cell location, the data you typed appeared in the Formula Bar. The Formula Bar can be used for entering data into cells as well as for editing data that already exists in a cell. The following steps provide an example of entering and then editing data that has been entered into a cell location:
Keyboard Shortcuts
Editing Data in a Cell
- Activate the cell that is to be edited and press the F2 key on your keyboard.
The Auto Fill feature is a valuable tool when manually entering data into a worksheet. This feature has many uses, but it is most beneficial when you are entering data in a defined sequence, such as the numbers 2, 4, 6, 8, and so on, or nonnumeric data such as the days of the week or months of the year. The following steps demonstrate how Auto Fill can be used to enter the months of the year in Column A:
Left click and drag the Fill Handle to cell A14. Notice that the Auto Fill tip box indicates what month will be placed into each cell (see Figure 1.19). Release the left mouse button when the tip box reads “December.”
Once you release the left mouse button, all twelve months of the year should appear in the cell range A3:A14, as shown in Figure 1.20. You will also see the Auto Fill Options button. By clicking this button, you have several options for inserting data into a group of cells.
There are several methods for removing data from a worksheet, a few of which are demonstrated here. With each method, you use the Undo command. This is a helpful command in the event you mistakenly remove data from your worksheet. The following steps demonstrate how you can delete data from a cell or range of cells:
Keyboard Shortcuts
Undo Command
- Hold down the CTRL key while pressing the letter Z on your keyboard.
- Highlight the range C2:C14 by placing the mouse pointer over cell C2. Then left click and drag the mouse pointer down to cell C14.
- Click the Clear button in the Home tab of the Ribbon, which is next to the Cells group of commands (see Figure 1.22). This opens a drop-down menu that contains several options for removing or clearing data from a cell. Notice that you also have options for clearing just the formats in a cell or the hyperlinks in a cell.
- Click the Clear All option. This removes the data in the cell range.
- Click the Undo button. This replaces the data in the range C2:C14.
There are a few entries in the worksheet that appear cut off. For example, the last letter of the word September cannot be seen in cell A11. This is because the column is too narrow for this word. The columns and rows on an Excel worksheet can be adjusted to accommodate the data that is being entered into a cell. The following steps explain how to adjust the column widths and row heights in a worksheet:
You may find that using the click-and-drag method is inefficient if you need to set a specific character width for one or more columns. Steps 1 through 6 illustrate a second method for adjusting column widths when using a specific number of characters:
Keyboard Shortcuts
Column Width
- Press the ALT key on your keyboard, then press the letters H, O, and W one at a time.
Steps 1 through 4 demonstrate how to adjust row height, which is similar to adjusting column width:
Keyboard Shortcuts
Row Height
- Press the ALT key on your keyboard, then press the letters H, O, and H one at a time.
Figure 1.25 shows the appearance of the worksheet after Column A and Row 15 are adjusted.
Skill Refresher
Adjusting Columns and Rows
- Activate at least one cell in the row or column you are adjusting.
- Click the Home tab of the Ribbon.
- Click the Format button in the Cells group.
- Click either Row Height or Column Width from the drop-down menu.
- Enter the Row Height in points or Column Width in characters in the dialog box.
- Click the OK button.
In addition to adjusting the columns and rows on a worksheet, you can also hide columns and rows. This is a useful technique for enhancing the visual appearance of a worksheet that contains data that is not necessary to display. These features will be demonstrated using the GMW Sales Data workbook. However, there is no need to have hidden columns or rows for this worksheet. The use of these skills here will be for demonstration purposes only.
Keyboard Shortcuts
Hiding Columns
- Hold down the CTRL key while pressing the number 0 on your keyboard.
Figure 1.27 shows the workbook with Column C hidden in the Sheet1 worksheet. You can tell a column is hidden by the missing letter C.
To unhide a column, follow these steps:
Keyboard Shortcuts
Unhiding Columns
- Highlight cells on either side of the hidden column(s), then hold down the CTRL key and the SHIFT key while pressing the close parenthesis key ()) on your keyboard.
The following steps demonstrate how to hide rows, which is similar to hiding columns:
Keyboard Shortcuts
Hiding Rows
- Hold down the CTRL key while pressing the number 9 key on your keyboard.
To unhide a row, follow these steps:
Keyboard Shortcuts
Unhiding Rows
- Highlight cells above and below the hidden row(s), then hold down the CTRL key and the SHIFT key while pressing the open parenthesis key (() on your keyboard.
Integrity Check
Hidden Rows and Columns
In most careers, it is common for professionals to use Excel workbooks that have been designed by a coworker. Before you use a workbook developed by someone else, always check for hidden rows and columns. You can quickly see whether a row or column is hidden if a row number or column letter is missing.
Skill Refresher
Hiding Columns and Rows
- Activate at least one cell in the row(s) or column(s) you are hiding.
- Click the Home tab of the Ribbon.
- Click the Format button in the Cells group.
- Place the mouse pointer over the Hide & Unhide option.
- Click either the Hide Rows or Hide Columns option.
Skill Refresher
Unhiding Columns and Rows
- Highlight the cells above and below the hidden row(s) or to the left and right of the hidden column(s).
- Click the Home tab of the Ribbon.
- Click the Format button in the Cells group.
- Place the mouse pointer over the Hide & Unhide option.
- Click either the Unhide Rows or Unhide Columns option.
Using Excel workbooks that have been created by others is a very efficient way to work because it eliminates the need to create data worksheets from scratch. However, you may find that to accomplish your goals, you need to add additional columns or rows of data. In this case, you can insert blank columns or rows into a worksheet. The following steps demonstrate how to do this:
Keyboard Shortcuts
Inserting Columns
- Press the ALT key and then the letters H, I, and C one at a time. A column will be inserted to the left of the activated cell.
Keyboard Shortcuts
Inserting Rows
- Press the ALT key and then the letters H, I, and R one at a time. A row will be inserted above the activated cell.
Skill Refresher
Inserting Columns and Rows
- Activate the cell to the right of the desired blank column or below the desired blank row.
- Click the Home tab of the Ribbon.
- Click the down arrow on the Insert button in the Cells group.
- Click either the Insert Sheet Columns or Insert Sheet Rows option.
Once data are entered into a worksheet, you have the ability to move it to different locations. The following steps demonstrate how to move data to different locations on a worksheet:
Integrity Check
Moving Data
Before moving data on a worksheet, make sure you identify all the components that belong with the series you are moving. For example, if you are moving a column of data, make sure the column heading is included. Also, make sure all values are highlighted in the column before moving it.
You may need to delete entire columns or rows of data from a worksheet. This need may arise if you need to remove either blank columns or rows from a worksheet or columns and rows that contain data. The methods for removing cell contents were covered earlier and can be used to delete unwanted data. However, if you do not want a blank row or column in your workbook, you can delete it using the following steps:
Keyboard Shortcuts
Deleting Rows
- Press the ALT key and then the letters H, D, and R one at a time. The row with the activated cell will be deleted.
Keyboard Shortcuts
Deleting Columns
- Press the ALT key and then the letters H, D, and C one at a time. The column with the activated cell will be deleted.
Skill Refresher
Deleting Columns and Rows
- Activate any cell in the row or column that is to be deleted.
- Click the Home tab of the Ribbon.
- Click the down arrow on the Delete button in the Cells group.
- Click either the Delete Sheet Columns or the Delete Sheet Rows option.
Key Takeaways
- Column headings should be used in a worksheet and should accurately describe the data contained in each column.
- Using symbols such as dollar signs when entering numbers into a worksheet can slow down the data entry process.
- Worksheets must be carefully proofread when data has been manually entered.
- The Undo command is a valuable tool for recovering data that was deleted from a worksheet.
- When using a worksheet that was developed by someone else, look carefully for hidden columns or rows.
Adapted by Barbara Lave from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Use formatting techniques as introduced in the Excel Spreadsheet Guidelines to enhance the appearance of a worksheet.
- Understand how to align data in cell locations.
- Examine how to enter multiple lines of text in a cell location.
- Understand how to add borders to a worksheet.
- Examine how to use the AutoSum feature to calculate totals.
- Use the Cut, Copy, and Paste commands to manipulate the data on a worksheet.
- Understand how to move, rename, insert, and delete worksheet tabs.
This section addresses formatting commands that can be used to enhance the visual appearance of a worksheet. It also provides an introduction to mathematical calculations. The skills introduced in this section will give you powerful tools for analyzing the data that we have been working with in this workbook and will highlight how Excel is used to make key decisions in virtually any career. Additionally, Excel Spreadsheet Guidelines for format and appearance will be introduced as a format for the course and spreadsheets submitted.
Enhancing the visual appearance of a worksheet is a critical step in creating a valuable tool for you or your coworkers when making key decisions. There are accepted professional formatting standards when spreadsheets contain only currency data. For this course, we will use the following Excel Guidelines for Formatting. The first figure displays how to use Accounting number format when ALL figures are currency. Only the first row of data and the totals should be formatted with the Accounting format. The other data should be formatted with Comma style. There also needs to be a Top Border above the numbers in the total row. If any of the numbers have cents, you need to format all of the data with two decimal places.
![]()
Figure 1.31a
Often, your Excel spreadsheet will contain values that are both currency and non-currency in nature. When that is the case, you’ll want to use the guidelines in the following figure:
The following steps demonstrate several fundamental formatting skills that will be applied to the workbook that we are developing for this chapter. Several of these formatting skills are identical to ones that you may have already used in other Microsoft applications such as Microsoft® Word® or Microsoft® PowerPoint®.
Figure 1.32 Font Group of Commands
Keyboard Shortcuts
Bold Format
- Hold the CTRL key while pressing the letter B on your keyboard.
Keyboard Shortcuts
Italics Format
- Hold the CTRL key while pressing the letter I on your keyboard.
Keyboard Shortcuts
Underline Format
- Hold the CTRL key while pressing the letter U on your keyboard.
Why?
Format Column Headings and Totals
Applying formatting enhancements to the column headings and column totals in a worksheet is a very important technique, especially if you are sharing a workbook with other people. These formatting techniques allow users of the worksheet to clearly see the column headings that define the data. In addition, the column totals usually contain the most important data on a worksheet with respect to making decisions, and formatting techniques allow users to quickly see this information.
Why?
Pound Signs (####) Appear in Columns
When a column is too narrow for a long number, Excel will automatically convert the number to a series of pound signs (####). In the case of words or text data, Excel will only show the characters that fit in the column. However, this is not the case with numeric data because it can give the appearance of a number that is much smaller than what is actually in the cell. To remove the pound signs, increase the width of the column.
Figure 1.35 shows how the Sheet1 worksheet should appear after the formatting techniques are applied.
The skills presented in this segment show how data are aligned within cell locations. For example, text and numbers can be centered in a cell location, left justified, right justified, and so on. In some cases you may want to stack multiword text entries vertically in a cell instead of expanding the width of a column. This is referred to as wrapping text. These skills are demonstrated in the following steps:
Keyboard Shortcuts
Wrap Text
- Press the ALT key and then the letters H and W one at a time.
Why?
Wrap Text
The benefit of using the Wrap Text command is that it significantly reduces the need to expand the column width to accommodate multiword column headings. The problem with increasing the column width is that you may reduce the amount of data that can fit on a piece of paper or one screen. This makes it cumbersome to analyze the data in the worksheet and could increase the time it takes to make a decision.
Keyboard Shortcuts
Merge Commands
- Merge & Center: Press the ALT key and then the letters H, M, and C one at a time.
- Merge Cells: Press the ALT key and then the letters H, M, and M one at a time.
- Unmerge Cells: Press the ALT key and then the letters H, M, and U one at a time.
Why?
Merge & Center
One of the most common reasons the Merge & Center command is used is to center the title of a worksheet directly above the columns of data. Once the cells above the column headings are merged, a title can be centered above the columns of data. It is very difficult to center the title over the columns of data if the cells are not merged.
Figure 1.38 shows the Sheet1 worksheet with the data alignment commands applied. The reason for merging the cells in the range A1:D1 will become apparent in the next segment.
Skill Refresher
Wrap Text
- Activate the cell or range of cells that contain text data.
- Click the Home tab of the Ribbon.
- Click the Wrap Text button.
Skill Refresher
Merge Cells
- Highlight a range of cells that will be merged.
- Click the Home tab of the Ribbon.
- Click the down arrow next to the Merge & Center button.
- Select an option from the Merge & Center list.
In the Sheet1 worksheet, the cells in the range A1:D1 were merged for the purposes of adding a title to the worksheet. This worksheet will contain both a title and a subtitle. The following steps explain how you can enter text into a cell and determine where you want the second line of text to begin:
Skill Refresher
Entering Multiple Lines of Text
- Activate a cell location.
- Type the first line of text.
- Hold down the ALT key and press the ENTER key.
- Type the second line of text and press the ENTER key.
In Excel, adding custom lines to a worksheet is known as adding borders. Borders are different from the grid lines that appear on a worksheet and that define the perimeter of the cell locations. The Borders command lets you add a variety of line styles to a worksheet that can make reading the worksheet much easier. The following steps illustrate methods for adding preset borders and custom borders to a worksheet:
Skill Refresher
Preset Borders
- Highlight a range of cells that require borders.
- Click the Home tab of the Ribbon.
- Click the down arrow next to the Borders button.
- Select an option from the preset borders list.
Custom Borders
- Highlight a range of cells that require borders.
- Click the Home tab of the Ribbon.
- Click the down arrow next to the Borders button.
- Select the More Borders option at the bottom of the options list.
- Select a line style and line color.
- Select a placement option.
- Click the OK button on the dialog box.
You will see at the bottom of Figure 1.42 that Row 15 is intended to show the totals for the data in this worksheet. Applying mathematical computations to a range of cells is accomplished through functions in Excel. Chapter 2 “Mathematical Computations” will review mathematical formulas and functions in detail. However, the following steps will demonstrate how you can quickly sum the values in a column of data using the AutoSum command:
Skill Refresher
AutoSum
- Highlight a cell location below or to the right of a range of cells that contain numeric values.
- Click the Formulas tab of the Ribbon.
- Click the down arrow below the AutoSum button.
- Select a mathematical function from the list.
The default names for the worksheet tabs at the bottom of workbook are Sheet1, Sheet2, and so on. However, you can change the worksheet tab names to identify the data you are using in a workbook. Additionally, you can change the order in which the worksheet tabs appear in the workbook. The following steps explain how to rename and move the worksheets in a workbook:
Integrity Check
Deleting Worksheets
Be very cautious when deleting worksheets that contain data. Once a worksheet is deleted, you cannot use the Undo command to bring the sheet back. Deleting a worksheet is a permanent command.
Keyboard Shortcuts
Inserting New Worksheets
- Press the SHIFT key and then the F11 key on your keyboard.
Figure 1.46 shows the final appearance of the GMW Sales workbook.
Skill Refresher
Renaming Worksheets
- Double click the worksheet tab.
- Type the new name.
- Press the ENTER key.
Moving Worksheets
- Left click the worksheet tab.
- Drag it to the desired position.
Deleting Worksheets
- Open the worksheet to be deleted.
- Click the Home tab of the Ribbon.
- Click the down arrow on the Delete button.
- Select the Delete Sheet option.
- Click Delete on the warning box.
Key Takeaways
- Formatting skills are critical for creating worksheets that are easy to read and have a professional appearance.
- A series of pound signs (####) in a cell location indicates that the column is too narrow to display the number entered.
- Using the Wrap Text command allows you to stack multiword column headings vertically in a cell location, reducing the need to expand column widths.
- Use the Merge & Center command to center the title of a worksheet directly over the columns that contain data.
- Adding borders or lines will make your worksheet easier to read and helps to separate the data in each column and row.
- You cannot use the Undo command to bring back a worksheet that has been deleted.
Adapted by Barbara Lave from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Use the Page Layout tab to prepare a worksheet for printing.
- Add headers and footers to a printed worksheet.
- Examine how to print worksheets and workbooks.
Once you have completed a workbook, it is good practice to select the appropriate settings for printing. These settings are in the Page Layout tab of the Ribbon and discussed in this section of the chapter.
Before you can properly print the worksheets in a workbook, you must establish appropriate settings. The following steps explain several of the commands in the Page Layout tab of the Ribbon used to prepare a worksheet for printing:
Why?
Use Print Settings
Because professionals often share Excel workbooks, it is a good practice to select the appropriate print settings in the Page Layout tab even if you do not intend to print the worksheets in a workbook. It can be extremely frustrating for recipients of a workbook who wish to print your worksheets to find that the necessary print settings have not been selected. This may reflect poorly on your attention to detail, especially if the recipient of the workbook is your boss.
Table 1.2 Printing Resources: Purpose and Use for Page Setup Commands
Command | Purpose | Use |
Margins | Sets the top, bottom, right, and left margin space for the printed document | 1. Click the Page Layout tab of the Ribbon. |
2. Click the Margin button. | ||
3. Click one of the preset margin options or click Custom Margins. | ||
Orientation | Sets the orientation of the printed document to either portrait or landscape | 1. Click the Page Layout tab of the Ribbon. |
2. Click the Orientation button. | ||
3. Click one of the preset orientation options. | ||
Size | Sets the paper size for the printed document | 1. Click the Page Layout tab of the Ribbon. |
2. Click the Size button. | ||
3. Click one of the preset paper size options or click More Paper Sizes. | ||
Print Area | Used for printing only a specific area or range of cells on a worksheet | 1. Highlight the range of cells on a worksheet that you wish to print. |
2. Click the Page Layout tab of the Ribbon. | ||
3. Click the Print Area button. | ||
4. Click the Set Print Area option from the drop-down list. | ||
Breaks | Allows you to manually set the page breaks on a worksheet | 1. Activate a cell on the worksheet where the page break should be placed. Breaks are created above and to the left of the activated cell. |
2. Click the Page Layout tab of the Ribbon. | ||
3. Click the Breaks button. | ||
4. Click the Insert Page Break option from the drop-down list. | ||
Background | Adds a picture behind the cell locations in a worksheet | 1. Click the Page Layout tab of the Ribbon. |
2. Click the Background button. | ||
3. Select a picture stored on your computer or network. | ||
Print Titles | Used when printing large data sets that are several pages long. This command will repeat the column headings at the top of each printed page. | 1. Click the Page Layout tab of the Ribbon. |
2. Click the Print Titles button. | ||
3. Click in the Rows to Repeat at Top input box in the Page Setup dialog box. | ||
4. Click any cell in the row that contains the column headings for your worksheet. | ||
5. Click the OK button at the bottom of the Page Setup dialog box. | ||
When printing worksheets from Excel, it is common to add headers and footers to the printed document. Information in the header or footer could include the date, page number, file name, company name, and so on. The following steps explain how to add headers and footers to the GMW Sales Data workbook:
Once you have established the print settings for the worksheets in a workbook and have added headers and footers, you are ready to print your worksheets. The following steps explain how to print the worksheets in the GMW Sales workbook:
Key Takeaways
- The commands in the Page Layout tab of the Ribbon are used to prepare a worksheet for printing.
- You can add headers and footers to a worksheet to show key information such as page numbers, the date, the file name, your name, and so on.
- The Print commands are in the File tab of the Ribbon.
Adapted by Barbara Lave from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
To assess your understanding of the material covered in the chapter, complete the following assignment.
Download Data File: PR1 Data
Creating and maintaining budgets are common practices in many careers. Budgets play a critical role in helping a business or household control expenditures. In this exercise you will create a budget for a hypothetical medical office while reviewing the skills covered in this chapter.
Adapted by Barbara Lave from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Download Data File: SC1 Data
A key activity for marketing professionals is to analyze projected sales and inventory information. This is especially important for retail environments. This exercise utilizes the skills covered in this chapter to analyze sales and inventory data.
Adapted by Barbara Lave from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Chapter 2 - Mathematical Computations
Perhaps the most valuable feature of Excel is its ability to produce mathematical outputs using the data in a workbook. This chapter reviews several mathematical outputs that you can produce in Excel through the construction of formulas and functions. The chapter begins with the construction of formulas for basic and complex mathematical computations. The second section reviews statistical functions, such as SUM, AVERAGE, MIN, and MAX, which can be applied to a range of cells. The last section of the chapter addresses functions used to calculate mortgage and lease payments as well as the valuation of investments. This chapter also shows how you can use data from multiple worksheets to construct formulas and functions. These skills will be demonstrated in the context of a personal cash budget, which is a vital tool for managing your money for long-term financial security. The personal budget objective will also provide you with several opportunities to demonstrate Excel’s what-if scenario capabilities, which highlight how formulas and functions automatically produce new outputs when one or more inputs are changed.
Adapted by Mary Schatz from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Learn how to create basic formulas.
- Understand relative referencing when copying and pasting formulas.
- Work with complex formulas by controlling the order of mathematical operations.
- Understand formula auditing tools.
This section reviews the fundamental skills for entering formulas into an Excel worksheet. The objective used for this chapter is the construction of a personal cash budget. Most financial advisors recommend that all households construct and maintain a personal budget to achieve and maintain strong financial health. Organizing and maintaining a personal budget is a skill you can practice at any point in your life. Whether you are managing your expenses during college or maintaining the finances of a family of four, a personal budget can be a vital tool when making financial decisions. Excel can make managing your money a fun and rewarding exercise.
Figure 2.1 shows the completed workbook that will be demonstrated in this chapter. Notice that this workbook contains four worksheets. The first worksheet, Budget Summary, contains formulas that utilize or reference the data in the other three worksheets. As a result, the Budget Summary worksheet serves as an overview of the data that was entered and calculated in the other three worksheets of the workbook.
Download Data File: CH2 Data
Formulas are used to calculate a variety of mathematical outputs in Excel and can be used to create virtually any custom calculation required for your objective. Furthermore, when constructing a formula in Excel, you use cell locations that, when added to a formula, become cell references. This means that Excel uses, or references, the number entered into the cell location when calculating a mathematical output. As a result, when the numbers in the cell references are changed, Excel automatically produces a new output. This is what gives Excel the ability to create a variety of what-if scenarios, which will be explained later in the chapter.
To demonstrate the construction of a basic formula, we will begin working on the Budget Detail worksheet in the Personal Budget workbook, which is shown in Figure 2.2. To complete this worksheet, we will add several formulas and functions. Table 2.1 provides definitions for each of the spend categories listed in the range A3:A11. When you develop a personal budget, these categories are defined on the basis of how you spend your money. It is likely that every person could have different categories or define the same categories differently. Therefore, it is important to review the definitions in Table 2.1 to understand how we are defining these categories before proceeding.
Table 2.1 Spend Category Definitions
Category | Definition |
Household Utilities | Money spent on electricity, heat, and water and on cable, phone, and Internet access |
Food | Money spent on groceries, toiletries, and related items |
Gasoline | Money spent on fuel for automobiles |
Clothes | Money spent on clothes, shoes, and accessories |
Insurance | Money spent on homeowner’s or automobile insurance |
Taxes | Money spent on school and property taxes (this example of the personal budget assumes that we own property). |
Entertainment | Money spent on entertainment, including dining out, movie and theater tickets, parties, and so on |
Vacation | Money spent on vacations |
Miscellaneous | Includes any other spending categories, such as textbooks, software, journals, school or work supplies, and so on |
The first formula that we will add to the Budget Detail worksheet will calculate the Monthly Spend values. The formula will be constructed so that it takes the values in the Annual Spend column and divides them by 12. This will show how much money will be spent per month for each of the categories listed in Column A. The following explains how this formula is created:
Table 2.2 Excel Mathematical Operators
Symbol | Operation |
+ | Addition |
− | Subtraction |
/ | Division |
* | Multiplication |
^ | Power/Exponent |
Why?
Use Cell References
Cell references enable Excel to dynamically produce new outputs when one or more inputs in the referenced cells are changed. Cell references also allow you to trace how outputs are being calculated in a formula. As a result, you should never use a calculator to determine a mathematical output and type it into the cell location of a worksheet. Doing so eliminates Excel’s cell-referencing benefits as well as your ability to trace a formula to determine how outputs are being produced.
Figure 2.3 shows how the formula appears in cell C3 before you press the ENTER key. Figure 2.4 shows the output of the formula after you press the ENTER key. The Monthly Spend for Household Utilities is $250 because the formula is taking the Annual Spend in cell D3 and dividing it by 12. If the value in cell D3 is changed, the formula automatically produces a new output. We are calculating the spend per month for each category because people often get paid and are billed for these items on a monthly basis. This formula allows you to compare your monthly income to your monthly bills to determine whether you have enough income to pay these expenses.
Why?
Use Universal Constants
If you are using constants, or numerical values, in an Excel formula, they should be universal constants that do not change, such as the number of days in a week, weeks in a year, and so on. Do not type the values that exist in cell locations into an Excel formula. This will eliminate Excel’s cell-referencing benefits, which means if the value in the cell location you are using in a formula is changed, Excel will not be able to produce a new output.
Once a formula is typed into a worksheet, it can be copied and pasted to other cell locations. For example, Figure 2.4 shows the output of the formula that was entered into cell C3. However, this calculation needs to be performed for the rest of the cell locations in Column C. Since we used the D3 cell reference in the formula, Excel automatically adjusts that cell reference when the formula is copied and pasted into the rest of the cell locations in the column. This is called relative referencing and is demonstrated as follows:
Figure 2.5 shows the outputs added to the rest of the cell locations in the Monthly Spend column. For each row, the formula takes the value in the Annual Spend column and divides it by 12. You will also see that cell D6 has been double clicked to show the formula. Notice that Excel automatically changed the original cell reference of D3 to D6. This is the result of relative referencing, which means Excel automatically adjusts a cell reference relative to its original location when it is pasted into new cell locations. In this example, the formula was pasted into eight cell locations below the original cell location. As a result, Excel increased the row number of the original cell reference by a value of one for each row it was pasted into.
Why?
Use Relative Referencing
Relative referencing is a convenient feature in Excel. When you use cell references in a formula, Excel automatically adjusts the cell references when the formula is pasted into new cell locations. If this feature were not available, you would have to manually retype the formula when you want the same calculation applied to other cell locations in a column or row.
The next formula to be added to the Personal Budget workbook is the percent change over last year. This formula determines the difference between the values in the LY (Last Year) Spend column and shows the difference in terms of a percentage. This requires that the order of mathematical operations be controlled to get an accurate result. Table 2.3 shows the standard order of operations for a typical formula. To change the order of operations shown in the table, we use parentheses to process certain mathematical calculations first. This formula is added to the worksheet as follows:
Table 2.3 Standard Order of Mathematical Operations
Symbol | Order |
( ) | Override Standard Order: Any mathematical computations placed in parentheses are performed first and override the standard order of operations. If there are layers of parentheses used in a formula, Excel computes the innermost parentheses first and the outermost parentheses last. |
^ | First: Excel executes any exponential computations first. |
* or / | Second: Excel performs any multiplication or division computations second. When there are multiple instances of these computations in a formula, they are executed in order from left to right. |
+ or − | Third: Excel performs any addition or subtraction computations third. When there are multiple instances of these computations in a formula, they are executed in order from left to right. |
Figure 2.6 shows the formula that was added to the Budget Detail worksheet to calculate the percent change in spending. The parentheses were added to this formula to control the order of operations. Any mathematical computations placed in parentheses are executed first before the standard order of mathematical operations (see Table 2.3). In this case, if parentheses were not used, Excel would produce an erroneous result for this worksheet.
Figure 2.7 shows the result of the percent change formula if the parentheses are removed. The formula produces a result of a 299900% increase. Since there is no change between the LY spend and the budget Annual Spend, the result should be 0%. However, without the parentheses, Excel is following the standard order of operations. This means the value in cell E3 will be divided by E3 first (3,000/3,000), which is 1. Then, the value of 1 will be subtracted from the value in cell D3 (3,000−1), which is 2,999. Since cell F3 is formatted as a percentage, Excel expresses the output as an increase of 299900%.
Integrity Check
Does the Output of Your Formula Make Sense?
It is important to note that the accuracy of the output produced by a formula depends on how it is constructed. Therefore, always check the result of your formula to see whether it makes sense with data in your worksheet. As shown in Figure 2.7, a poorly constructed formula can give you an inaccurate result. In other words, you can see that there is no change between the Annual Spend and LY Spend for Household Utilities. Therefore, the result of the formula should be 0%. However, since the parentheses were removed in this case, the formula is clearly producing an erroneous result.
Skill Refresher
Formulas
- Type an equal sign =.
- Click or type a cell location. If using constants, type a number.
- Type a mathematical operator.
- Click or type a cell location. If using constants, type a number.
- Use parentheses where necessary to control the order of operations.
- Press the ENTER key.
Excel provides a few tools that you can use to review the formulas entered into a worksheet. For example, instead of showing the outputs for the formulas used in a worksheet, you can have Excel show the formula as it was entered in the cell locations. This is demonstrated as follows:
Figure 2.8 shows the Budget Detail worksheet after activating the Show Formulas command in the Formulas tab of the Ribbon. As shown in the figure, this command allows you to view and check all the formulas in a worksheet without having to click each cell individually. After activating this command, the column widths in your worksheet increase significantly. The column widths were adjusted for the worksheet shown in Figure 2.8 so all columns can be seen. The column widths return to their previous width when the Show Formulas command is deactivated.
Skill Refresher
Show Formulas
- Click the Formulas tab on the Ribbon.
- Click the Show Formulas button in the Formula Auditing group of commands.
- Click the Show Formulas button again to show formula outputs.
Keyboard Shortcuts
Show Formulas
- Hold down the CTRL key while pressing the accent symbol `.
Two other tools in the Formula Auditing group of commands are the Trace Precedents and Trace Dependents commands. These commands are used to trace the cell references used in a formula. A precedent cell is a cell whose value is used in other cells. The Trace Precedents command shows an arrow to indicate the cells or ranges (precedents) which affect the active cell’s value. A dependent cell is a cell whose value depends on the values of other cells in the workbook. The Trace Dependents command shows where any given cell is referenced in a formula. The following is a demonstration of these commands:
Figure 2.9 shows the Trace Dependents arrow on the Budget Detail worksheet. The blue dot represents the activated cell. The arrows indicate where the cell is referenced in formulas.
Figure 2.10 shows the Trace Precedents arrow on the Budget Detail worksheet. The blue dots on this arrow indicate the cells that are referenced in the formula contained in the activated cell. The arrow is pointing to the activated cell location that contains the formula.
Skill Refresher
Trace Dependents
- Click a cell location that contains a number or formula.
- Click the Formulas tab on the Ribbon.
- Click the Trace Dependents button in the Formula Auditing group of commands.
- Use the arrow(s) to determine where the cell is referenced in formulas and functions.
- Click the Remove Arrows button to remove the arrows from the worksheet.
Skill Refresher
Trace Precedents
- Click a cell location that contains a formula or function.
- Click the Formulas tab on the Ribbon.
- Click the Trace Precedents button in the Formula Auditing group of commands.
- Use the dot(s) along the line to determine what cells are referenced in the formula or function.
- Click the Remove Arrows button to remove the line with the dots.
Key Takeaways
- Mathematical computations are conducted through formulas and functions.
- An equal sign = precedes all formulas and functions.
- Formulas and functions must be created with cell references to conduct what-if scenarios where mathematical outputs are recalculated when one or more inputs are changed.
- Mathematical operators on a typical calculator are different from those used in Excel. Table 2.2 “Excel Mathematical Operators” lists Excel mathematical operators.
- When using numerical values in formulas and functions, only use universal constants that do not change, such as days in a week, months in a year, and so on.
- Relative referencing automatically adjusts the cell references in formulas and functions when they are pasted into new locations on a worksheet. This eliminates the need to retype formulas and functions when they are needed in multiple rows or columns on a worksheet.
- Parentheses must be used to control the order of operations when necessary for complex formulas.
- Formula auditing tools such as Trace Dependents, Trace Precedents, and Show Formulas should be used to check the integrity of formulas that have been entered into a worksheet.
Adapted by Mary Schatz from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Use the SUM function to calculate totals.
- Use absolute references to calculate percent of totals.
- Use the COUNT function to count cell locations with numerical values.
- Use the AVERAGE function to calculate the arithmetic mean.
- Use the MAX and MIN functions to find the highest and lowest values in a range of cells.
- Learn how to copy and paste formulas without formats applied to a cell location.
- Learn how to set a multiple level sort sequence for data sets that have duplicate values or outputs.
In addition to formulas, another way to conduct mathematical computations in Excel is through functions. Statistical functions apply a mathematical process to a group of cells in a worksheet. For example, the SUM function is used to add the values contained in a range of cells. A list of commonly used statistical functions is shown in Table 2.4. Functions are more efficient than formulas when you are applying a mathematical process to a group of cells. If you use a formula to add the values in a range of cells, you would have to add each cell location to the formula one at a time. This can be very time-consuming if you have to add the values in a few hundred cell locations. However, when you use a function, you can highlight all the cells that contain values you wish to sum in just one step. This section demonstrates a variety of statistical functions that we will add to the Personal Budget workbook. In addition to demonstrating functions, this section also reviews percent of total calculations and the use of absolute references.
Table 2.4 Commonly Used Statistical Functions
Function | Output |
ABS | The absolute value of a number |
AVERAGE | The average or arithmetic mean for a group of numbers |
COUNT | The number of cell locations in a range that contain a numeric character |
COUNTA | The number of cell locations in a range that contain a text or numeric character |
MAX | The highest numeric value in a group of numbers |
MEDIAN | The middle number in a group of numbers (half the numbers in the group are higher than the median and half the numbers in the group are lower than the median) |
MIN | The lowest numeric value in a group of numbers |
MODE | The number that appears most frequently in a group of numbers |
PRODUCT | The result of multiplying all the values in a range of cell locations |
SQRT | The positive square root of a number |
STDEV.S | The standard deviation for a group of numbers based on a sample |
SUM | The total of all numeric values in a group |
The SUM function is used when you need to calculate totals for a range of cells or a group of selected cells on a worksheet. With regard to the Budget Detail worksheet, we will use the SUM function to calculate the totals in row 12. It is important to note that there are several methods for adding a function to a worksheet, which will be demonstrated throughout the remainder of this chapter. The following illustrates how a function can be added to a worksheet by typing it into a cell location:
Figure 2.11 shows the appearance of the SUM function added to the Budget Detail worksheet before pressing the ENTER key.
As shown in Figure 2.11, the SUM function was added to cell C12. However, this function is also needed to calculate the totals in the Annual Spend and LY Spend columns. The function can be copied and pasted into these cell locations because of relative referencing. Relative referencing serves the same purpose for functions as it does for formulas. The following demonstrates how the total row is completed:
Figure 2.12 shows the output of the SUM function that was added to cells C12, D12, and E12. In addition, the percent change formula was copied and pasted into cell F12. Notice that this version of the budget is planning a 1.7% decrease in spending compared to last year.
Integrity Check
Cell Ranges in Statistical Functions
When you intend to use a statistical function on a range of cells in a worksheet, make sure there are two cell locations separated by a colon and not a comma. If you enter two cell locations separated by a comma, the function will produce an output but it will be applied to only two cell locations instead of a range of cells. For example, the SUM function shown in Figure 2.13 will add only the values in cells C3 and C11, not the range C3:C11.
Data file: Continue with CH2 Personal Budget.
Since totals were added to row 12 of the Budget Detail worksheet, a percent of total calculation can be added to Column B beginning in cell B3. The percent of total calculation shows the percentage for each value in the Annual Spend column with respect to the total in cell D12. However, after the formula is created, it will be necessary to turn off Excel’s relative referencing feature before copying and pasting the formula to the rest of the cell locations in the column. Turning off Excel’s relative referencing feature is accomplished through an absolute reference. The following steps explain how this is done:
Figure 2.14 shows the completed formula that is calculating the percentage that Household Utilities Annual Spend represents to the total Annual Spend for the budget (see cell B3). Normally, we would copy this formula and paste it into the range B4:B11. However, because of relative referencing, both cell references will increase by one row as the formula is pasted into the cells below B3. This is fine for the first cell reference in the formula (D3) but not for the second cell reference (D12). Figure 2.15 illustrates what happens if we paste the formula into the range B4:B12 in its current state. Notice that Excel produces the #DIV/0 error code. This means that Excel is trying to divide a number by zero, which is impossible. Looking at the formula in cell B4, you see that the first cell reference was changed from D3 to D4. This is fine because we now want to divide the Annual Spend for Insurance by the total Annual Spend in cell D12. However, Excel has also changed the D12 cell reference to D13. Because cell location D13 is blank, the formula produces the #DIV/0 error code.
To eliminate the divide-by-zero error shown in Figure 2.15 we must add an absolute reference to cell D12 in the formula. An absolute reference prevents relative referencing from changing a cell reference in a formula. This is also referred to as locking a cell. The following explains how this is accomplished:
Figure 2.16 shows the percent of total formula with an absolute reference added to D12. Notice that in cell B4, the cell reference remains D12 instead of changing to D13 as shown in Figure 2.15. Also, you will see that the percentages are being calculated in the rest of the cells in the column, and the divide-by-zero error is now eliminated.
Skill Refresher
Absolute References
- Click in front of the column letter of a cell reference in a formula or function that you do not want altered when the formula or function is pasted into a new cell location.
- Press the F4 key or type a dollar sign $ in front of the column letter and row number of the cell reference.
Data file: Continue with CH2 Personal Budget.
The next function that we will add to the Budget Detail worksheet is the COUNT function. The COUNT function is used to determine how many cells in a range contain a numeric entry. The COUNT function will not work for counting text or other non-numeric entries. For the Budget Detail worksheet, we will use the COUNT function to count the number of items that are planned in the Annual Spend column (Column D). The following explains how the COUNT function is added to the worksheet by using the function list:
Figure 2.17 shows the function list box that appears after completing steps 2 and 3 for the COUNT function. The function list provides an alternative method for adding a function to a worksheet.
Figure 2.18 shows the output of the COUNT function after pressing the ENTER key. The function counts the number of cells in the range D3:D11 that contain a numeric value. The result of 9 indicates that there are 9 categories planned for this budget.
The next function we will add to the Budget Detail worksheet is the AVERAGE function. This function is used to calculate the arithmetic mean for a group of numbers. For the Budget Detail worksheet, we will use the function to calculate the average of the values in the Annual Spend column. We will add this to the worksheet by using the Function Library. The following steps explain how this is accomplished:
Figure 2.19 illustrates how a function is selected from the Function Library in the Formulas tab of the Ribbon.
Figure 2.20 shows the Function Arguments dialog box. This appears after a function is selected from the Function Library. The Collapse Dialog button is used to hide the dialog box so a range of cells can be highlighted on the worksheet and then added to the function.
Figure 2.21 shows how a range of cells can be selected from the Function Arguments dialog box once it has been collapsed.
Figure 2.22 shows the Function Arguments dialog box after the cell range is defined for the AVERAGE function. The dialog box shows the result of the function before it is added to the cell location. This allows you to assess the function output to determine whether it makes sense before adding it to the worksheet.
Figure 2.23 shows the completed AVERAGE function in the Budget Detail worksheet. The output of the function shows that on average we expect to spend $1,994 for each of the categories listed in Column A of the budget. This average spend calculation per category can be used as an indicator to determine which categories are costing more or less than the average budgeted spend dollars.
Data file: Continue with CH2 Personal Budget.
The final two statistical functions that we will add to the Budget Detail worksheet are the MAX and MIN functions. These functions identify the highest and lowest values in a range of cells. The following steps explain how to add these functions to the Budget Detail worksheet:
Skill Refresher
Statistical Functions
- Type an equal sign =.
- Type the function name followed by an open parenthesis ( or double click the function name from the function list.
- Highlight a range on a worksheet or click individual cell locations followed by commas.
- Type a closing parenthesis ) and press the ENTER key or press the ENTER key to close the function.
Data file: Continue with CH2 Personal Budget.
As shown in Figure 2.25, the COUNT, AVERAGE, MIN, and MAX functions are summarizing the data in the Annual Spend column. You will also notice that there is space to copy and paste these functions under the LY Spend column. This allows us to compare what we spent last year and what we are planning to spend this year. Normally, we would simply copy and paste these functions into the range E13:E16. However, you may have noticed the double-line style border that was used around the perimeter of the range B13:E16. If we used the regular Paste command, the double line on the right side of the range E13:E16 would be replaced with a single line. Therefore, we are going to use one of the Paste Special commands to paste only the functions without any of the formatting treatments. This is accomplished through the following steps:
Figure 2.26 shows the list of buttons that appear when you click the down arrow below the Paste button in the Home tab of the Ribbon. One thing to note about these options is that you can preview them before you make a selection by dragging the mouse pointer over the options. As shown in the figure, when the mouse pointer is placed over the Formulas button, you can see how the functions will appear before making a selection. Notice that the double-line border does not change when this option is previewed. That is why this selection is made instead of the regular Paste option.
Skill Refresher
Paste Formulas
- Click a cell location containing a formula or function.
- Click the Copy button in the Home tab of the Ribbon.
- Click the cell location or cell range where the formula or function will be pasted.
- Click the down arrow below the Paste button in the Home tab of the Ribbon.
- Click the Formulas button under the Paste group of buttons.
Data file: Continue with CH2 Personal Budget.
The Budget Detail worksheet shown in Figure 2.26 is now producing several mathematical outputs through formulas and functions. The outputs allow you to analyze the details and identify trends as to how money is being budgeted and spent. Before we draw some conclusions from this worksheet, we will sort the data based on the Percent of Total column. Sorting is a powerful tool that enables you to analyze key trends in any data set. Sorting will be covered thoroughly in a later chapter, but will be briefly introduced here. For the purposes of the Budget Detail worksheet, we want to set multiple levels for the sort order. This is accomplished through the following steps:
Figure 2.28 shows the Budget Detail worksheet after it has been sorted. Notice that there are three identical values in the Percent of Total column. This is why a second sort level had to be created for this worksheet. The second sort level arranges the values of 8.4% based on the values in the LY Spend column in ascending order. Excel gives you the option to set as many sort levels as necessary for the data contained in a worksheet.
Skill Refresher
Sorting Data (Multiple Levels)
- Highlight a range of cells to be sorted.
- Click the Data tab of the Ribbon.
- Click the Sort button in the Sort & Filter group.
- Select a column from the “Sort by” drop-down list in the Sort dialog box.
- Select a sort order from the Order drop-down list in the Sort dialog box.
- Click the Add Level button in the Sort dialog box.
- Repeat Steps 4 and 5.
- Click the OK button on the Sort dialog box.
Now that the Budget Detail worksheet is sorted, a few key trends can be easily identified. The worksheet clearly shows that the top three categories as a percentage of total budgeted spending for the year are Taxes, Household Utilities, and Food. All three categories are necessities (or realities) of life and typically require a significant amount of income for most households. Looking at the Percent Change column, we can see how our planned spending is expected to change from last year. This is perhaps the most important column on the worksheet because it allows you to assess whether your plan is realistic. You will see that there are no changes planned for Taxes and Household Utilities. While Taxes can change from year to year, it is not too difficult to predict what they will be. In this case, we are assuming that there are no changes to the tax costs for our budget. We are also planning no change in Household Utilities. These costs can fluctuate from year to year as well. However, you can take measures to reduce costs, such as using less electricity, turning off heat when no one is in the house, keeping track of your wireless minutes so you do not go over the maximum allowed in your plan, and so on. As a result, there is no change in planned spending for Household Utilities because we will assume that any rate increases will be offset with a decrease in usage. The third item that is planned not to change is Insurance. Insurance policies for cars and homes can change, but as is true for taxes, the changes are predictable. Therefore, we are assuming no changes in our insurance policy.
The first big change that is noticeable in the worksheet is the Food and Entertainment categories in rows 5 and 6 (see definitions in Table 2.1). The Percent Change column indicates that there is an 11.1% decrease in Entertainment spending and an 11.1% increase in Food spending. This is logical because if you plan to eat in restaurants less frequently, you will be eating at home more frequently. Although this makes sense in theory, it may be hard to do in practice. Dinners and parties with friends may be tough to turn down. However, the entire process of maintaining a budget is based on discipline, and it certainly takes a significant amount of discipline to plan targets for yourself and stick to them.
A few other points to note are the changes in the Gasoline and Vacation categories. If you commute to school or work, the price of gas can have a significant impact on your budget. It is important to be realistic if gas prices are increasing, and you should reflect these increases in your budget. To compensate for the increased spending for gas, the spending plan for vacations has been reduced by 25%. Budgeting often requires a certain degree of creativity. Although the Vacation budget has been reduced, there is still money you can set aside to make plans for spring break or winter break.
Finally, the budget shows a decrease in Miscellaneous spending of 19.8%. This was defined as a group containing several expenses, such as textbooks, school supplies, software updates, and so on (see Table 2.1). You may be able to reduce your spending in this category if you can use items such as online textbooks. This reduction in spending can free up funds for Clothes, a spend category that has increased by 20%. We will continue to develop the Personal Budget workbook further in Section 2.3 “Functions for Personal Finance”.
Key Takeaways
- Statistical functions are used when a mathematical process is required for a range of cells, such as summing the values in several cell locations. For these computations, functions are preferable to formulas because adding many cell locations one at a time to a formula can be very time-consuming.
- Statistical functions can be created using cell ranges or selected cell locations separated by commas. Make sure you use a cell range (two cell locations separated by a colon) when applying a statistical function to a contiguous range of cells.
- To prevent Excel from changing the cell references in a formula or function when they are pasted to a new cell location, you must use an absolute reference. You can do this by placing a dollar sign ($) in front of the column letter and row number of a cell reference.
- The #DIV/0 error appears if you create a formula that attempts to divide a constant or the value in a cell reference by zero.
- The Paste Formulas option is used when you need to paste formulas without any formatting treatments into cell locations that have already been formatted.
- You need to set multiple levels, or columns, in the Sort dialog box when sorting data that contains several duplicate values.
Adapted by Mary Schatz from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Understand the fundamentals of loans and leases.
- Use the PMT function to calculate monthly mortgage payments on a house.
- Use the PMT function to calculate monthly lease payments for an automobile.
- Learn how to summarize data in a workbook by using worksheet links to create a summary worksheet.
In this section, we continue to develop the Personal Budget workbook. Notable items that are missing from the Budget Detail worksheet are the payments you might make for a car or a home. This section demonstrates Excel functions used to calculate lease payments for a car and to calculate mortgage payments for a house.
One of the functions we will add to the Personal Budget workbook is the PMT function. This function calculates the payments required for a loan or a lease. However, before demonstrating this function, it is important to cover a few fundamental concepts on loans and leases.
A loan is a contractual agreement in which money is borrowed from a lender and paid back over a specific period of time. The amount of money that is borrowed from the lender is called the principal of the loan. The borrower is usually required to pay the principal of the loan plus interest. When you borrow money to buy a house, the loan is referred to as a mortgage. This is because the house being purchased also serves as collateral to ensure payment. In other words, the bank can take possession of your house if you fail to make loan payments. As shown in Table 2.5, there are several key terms related to loans and leases.
Table 2.5 Key Terms for Loans and Leases
Term | Definition |
Collateral | Any item of value that is used to secure a loan to ensure payments to the lender |
Down Payment | The amount of cash paid toward the purchase of a house. If you are paying 20% down, you are paying 20% of the cost of the house in cash and are borrowing the rest from a lender. |
Interest Rate | The interest that is charged to the borrower as a cost for borrowing money |
Mortgage | A loan where property is put up for collateral |
Principal | The amount of money that has been borrowed |
Residual Value | The estimated selling price of a vehicle at a future point in time |
Terms | The amount of time you have to repay a loan |
Figure 2.29 shows an example of an amortization table for a loan. A lender is required by law to provide borrowers with an amortization table when a loan contract is offered. The table in the figure shows how the payments of a loan would work if you borrowed $100,000 from a lender and agreed to pay it back over 10 years at an interest rate of 5%. You will notice that each time you make a payment, you are paying the bank an interest fee plus some of the loan principal. Each year the amount of interest paid to the bank decreases and the amount of money used to pay off the principal increases. This is because the bank is charging you interest on the amount of principal that has not been paid. As you pay off the principal, the interest rate is applied to a lower number, which reduces your interest charges. Finally, the figure shows that the sum of the values in the Interest Payment column is $29,505. This is how much it costs you to borrow this money over 10 years. Indeed, borrowing money is not free. It is important to note that to simplify this example, the payments were calculated on an annual basis. However, most loan payments are made on a monthly basis.
A lease is a contract in which you, the lessee, use an asset such as a car or a piece of equipment and you agree to make regular payments to the owner or the lessor. When you lease a car, the manufacturer or a leasing company retains ownership of the vehicle and you agree to make regular payments for a specific period of time. The amount of money you pay depends on the price of the car, the terms of the lease contract, and the car’s expected residual value at the end of the lease. The calculation of lease payments is similar to the calculation of loan payments. However, when you lease a car, you pay only the value of the car that is used. For example, suppose you are leasing a car that is priced at $25,000. The lease contract is for 4 years at an interest rate of 5%. The residual value of the car is $10,000. This means the car will lose $15,000 of its value over 4 years. Another way to state this is that the car will depreciate $15,000. A lease will be structured so that you pay this $15,000 in depreciation. However, the interest charges will be based on the purchase price of $25,000. We will look at a demonstration of leasing a car as well as buying a home in the next section.
Data file: Continue with CH2 Personal Budget.
If you own a home, your mortgage payments are a major component of your household budget. If you are planning to buy a home, having a clear understanding of your monthly payments is critical for maintaining strong financial health. In Excel, mortgage payments are conveniently calculated through the PMT (payment) function. This function is more complex than the statistical functions covered in Section 2.2 “Statistical Functions”. With statistical functions, you are required to add only a range of cells or selected cells within the parentheses of the function, also known as the argument. With the PMT function, you must accurately define a series of arguments in order for the function to produce a reliable output. Table 2.6 lists the arguments for the PMT function. It is helpful to review the key loan and lease terms in Table 2.5 before reviewing the PMT function arguments.
Table 2.6 Arguments for the PMT Function
Argument | Definition |
Rate | This is the interest rate the lender is charging the borrower. The interest rate is usually quoted in annual terms, so you have to divide this rate by 12 if you are calculating monthly payments. |
Nper | The argument letters stand for number of periods. This is the term of the loan, which is the amount of time you have to repay the bank. This is usually quoted in years, so you have to multiply the years by 12 if you are calculating monthly payments. |
Pv | The argument letters stand for present value. This is the principal of the loan or the amount of money that is borrowed. When defining this argument, a minus sign must precede the cell location or value. For leases, this argument is used for the price of the item being leased. |
[Fv] | The argument letters stand for future value. The brackets around the argument indicate that it is not always necessary to define it. It is used if there is a lump-sum payment that will be made at the end of the loan terms. This is also used for the residual value of a lease. If it is not defined, Excel will assume that it is zero. |
[Type] | This argument can be defined with either a 1 or a 0. The number 1 is used if payments are made at the beginning of each period. A 0 is used if payments are made at the end of each period. The argument is in brackets because it does not have to be defined if payments are made at the end of each period. Excel assumes that this argument is 0 if it is not defined. |
By default, the result of the PMT function in Excel is shown as a negative number. This is because it represents an outgoing payment. When making a mortgage or car payment, you are paying money out of your pocket or bank account. Depending on the type of work that you do, your employer may want you to leave your payments negative or they may ask you to format them as positive numbers. In the following assignments, the payments calculated using the PMT function will be made positive to make them easier to work with. To do this, when defining the PV argument (amount of money borrowed) in the PMT dialog box, a minus sign must precede the cell location or value (see the PV argument in Figure 2.32).
We will use the PMT function in the Personal Budget workbook to calculate the monthly mortgage payments for a house. These calculations will be made in the Mortgage Payments worksheet and then displayed in the Budget Summary worksheet through a cell reference link. So far we have demonstrated several methods for adding functions to a worksheet. The following steps explain a new method using the Insert Function command for adding the PMT function:
Keyboard Shortcuts
Insert Function
- Hold the SHIFT key while pressing the F3 key.
Function Arguments Dialog Box
- After the equal sign = and function name are typed into cell a location, hold down the CTRL key and press the letter A on your keyboard.
Figure 2.32 shows the completed Function Arguments dialog box for the PMT function. Notice that the dialog box shows the values for the Rate and Nper arguments. The Rate is divided by 12 to convert the annual interest rate to a monthly interest rate. The Nper argument is multiplied by 12 to convert the terms of the loan from years to months. Finally, the dialog box provides you with a definition for each argument. The definition appears when you click in the input box for the argument.
Integrity Check
Comparable Arguments for PMT Function
When using functions such as PMT, make sure the arguments are defined in comparable terms. For example, if you are calculating the monthly payments of a loan, make sure both the Rate and Nper argument are expressed in terms of months. The function will produce an erroneous result if one argument is expressed in years while the other is expressed in months.
Figure 2.33 shows the final appearance of the Mortgage Payments worksheet after the PMT function is added. The result of the function in cell B5 will be displayed in the Budget Summary worksheet.
In addition to calculating the mortgage payments for a home, the PMT function will be used in the Personal Budget workbook to calculate the lease payments for a car. The details for the lease payments are found in the Car Lease Payments worksheet. Similar to the statistical functions, we can either type the PMT function directly into a cell or use the Insert Function button. However, you must know the definitions for each argument of the function and understand how these arguments need to be defined based on your objective. The terms for loans and leases are in Table 2.5, and the definitions for the arguments of the PMT function are in Table 2.6. The following steps explain how the PMT function is added to the Personal Budget workbook to calculate the lease payments for a car:
Figure 2.34 shows how the the completed Function Arguments dialog box for the PMT function car lease should appear before pressing the OK button.
Figure 2.35 shows the result of the PMT function for the car lease. The monthly payments for this lease are $206.56. This monthly payment will be displayed in the Budget Summary worksheet.
Skill Refresher
PMT Function
- Type an equal sign =.
- Type the letters PMT followed by an open parenthesis, or double click the function name from the function list.
- Define the Rate argument with a cell location that contains the rate being charged by the lender for the loan or lease. If the interest rate given is an annual rate, divide it by 12 to convert it to a monthly rate.
- Define the Nper argument with a cell location that contains the amount of time to repay the loan or lease. If the amount of time is in years, multiply it by 12 to convert it to number of months.
- Define the Pv argument with a cell location that contains the principal of the loan or the price of the item being leased. Cell locations or values used for this argument must be preceded by a minus sign.
- Define the [Fv] argument with a cell location that contains the residual value of the item being leased or the lump sum payment for a loan.
- Define the [Type] argument with a 1 if payments are made at the beginning of each period or 0 if payments are made at the end of each period.
- Type a closing parenthesis ).
- Press the ENTER key.
So far we have used cell references in formulas and functions, which allow Excel to produce new outputs when the values in the cell references are changed. Cell references can also be used to display values or the outputs of formulas and functions in cell locations on other worksheets. This is how data will be displayed on the Budget Summary worksheet in the Personal Budget workbook. Outputs from the formulas and functions that were entered into the Budget Detail, Mortgage Payments, and Car Lease Payments worksheets will be displayed on the Budget Summary worksheet through the use of cell references. The following steps explain how this is accomplished:
Figure 2.36 shows how the cell reference appears in the Budget Summary worksheet. Notice that the cell reference D12 is preceded by the Budget Detail worksheet name enclosed in apostrophes followed by an exclamation point (‘Budget Detail’!) This indicates that the value displayed in the cell is referencing a cell location in the Budget Detail worksheet.
As shown in Figure 2.36, the Budget Summary worksheet is designed to show the expense budget for the mortgage payments and the auto lease payments. However, you will recall that we used the PMT function to calculate the monthly payments. In the Budget Summary worksheet, we need to show the total annual payments. As a result, we will create a formula that references cell locations in the Mortgage Payments and Car Lease Payments worksheets. The following steps explain how this is accomplished:
Figure 2.37 shows the results of creating formulas that reference cell locations in the Mortgage Payments and Car Lease Payments worksheets.
We can now add other formulas and functions to the Budget Summary worksheet that can calculate the difference between the total spend dollars vs. the total net income in cell D2. The following steps explain how this is accomplished:
Figure 2.38 shows the results of the formulas that were added to the Budget Summary worksheet. The output for the formula in cell D7 shows that the net income exceeds total planned expenses by $1,942. Overall, having your income exceed your total expenses is a good thing because it allows you to save money for future spending needs or unexpected events.
We can now add a few formulas that calculate both the spending rate and the savings rate as a percentage of net income. These formulas require the use of absolute references, which we covered earlier in this chapter. The following steps explain how to add these formulas:
Figure 2.39 shows the output of the formulas calculating the spending rate and savings rate as a percentage of net income. The absolute reference shown for cell D2 prevents the cell from changing when the formula is copied from cell E6 and pasted into cell E7. The results of the formula show that our current budget allows for a savings rate of 5.9%. This is a fairly good savings rate.
Key Takeaways
- The PMT function can be used to calculate the monthly mortgage payments for a house or the monthly lease payments for a car.
- When using the PMT function, each argument must be separated by a comma.
- To calculate the monthly payment for a loan using the PMT function, the Rate and Nper arguments must be defined in terms of months. The Rate should be divided by 12 to convert it from an annual rate to a monthly rate. The Nper should be multiplied by 12 to convert the term of the loan from years to months.
- The PMT function produces a negative output if the Pv argument is not preceded by a minus sign. For the purposes of this textbook, a minus sign will be entered before the PV argument in the PMT dialog box.
Adapted by Mary Schatz from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Review and learn new cell formatting techniques.
- Understand how to modify page scaling and margins.
- Create custom headers and footers to automatically update information.
In this section, we will review some of the formatting techniques covered in Chapter 1, as well as learn some new techniques. We will also preview a two-page worksheet and set page setup options to present the data in a professional manner. A new data file will be used in this section.
Download Data File: CH2 PTP Data
You have been given sales data that needs to be formatted in a professional manner. This worksheet will be printed and presented to investors, so it needs to be prepared for printing as well. Figure 2.40 shows how the finished worksheet will appear in Print Preview.
Once the worksheet is professionally formatted, you need to look in Print Preview to see how the pages will print.
Now that the entire worksheet is printing on one page, you need to add a footer with information about the date the file was printed along with the filename. In Chapter 1 you learned how to create headers and footers using the Insert ribbon. You can also create headers and footers using the Custom Header/Footer dialog box.
Key Takeaways
- It is important to always check your workbooks in Print Preview to ensure that the data is printed in a professional and easy to read manner.
- Adjust margins and page scaling as needed to keep columns of data together on one page if possible.
- Use headers and footers to display information in the top and bottom margins of the printed worksheet. Use the Insert buttons to insert changing information, such as dates and file names, instead of typing them in directly.
“2.4 Preparing to Print” by Julie Romey, Portland Community College is licensed under CC BY 4.0
Download Data File: PR2 Data
Running your own lawn care business can be an excellent way to make money over the summer while on break from college. It can also be a way to supplement your existing income for the purpose of saving money for retirement or for a college fund. However, managing the costs of the business will be critical in order for it to be a profitable venture. In this exercise you will create a simple financial plan for a lawn care business by using the skills covered in this chapter.
![]()
Figure 2.47a Completed Lawn Care Annual Plan Worksheet
Adapted by Mary Schatz from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Download Data File: SC2 Data
The hotel management industry presents a wide variety of career opportunities. These range from running a bed and breakfast to a management position at a large hotel. No matter what hotel management career you choose to pursue, understanding hotel occupancy and costs are critical to running a successful operation. This exercise examines the occupancy rate and expenses of a small hotel.
Figure 2.48 Terms for the purchase vs. lease of the car
Adapted by Mary Schatz from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Chapter 3 - Formulas, Functions, Logical and Lookup Functions
Excel workbooks are designed to allow you to create useful and complex calculations. In addition to doing arithmetic, you can use Excel to look up data, and to display results based on logical conditions. We will also look at ways to highlight specific results. These skills will be demonstrated in the context of a typical gradebook spreadsheet that contains the results for an imaginary Excel class.
In this chapter, we will:
Figure 3-1 shows the completed workbook that will be demonstrated in this chapter. Notice the techniques used in columns O and R that highlight the results of your calculations. Notice, also that there are more numbers on this version of the file than you will see in your original data file. These are all completed using Excel calculations.
Figure 3.1 Completed Gradebook Worksheet
Chapter 3 – Formulas, Functions, Logical and Lookup Functions by Noreen Brown and Mary Schatz, Portland Community College, is licensed under CC BY 4.0
Learning Objectives
- Review the use of the =MAX function.
- Examine the Quick Analysis Tool to create standard calculations, formatting, and charts very quickly.
- Create Percentage calculation.
– Use the Smart Lookup tool to acquire additional information about percentage calculations.
– Review the use of Absolute cell reference in a division formula.
Before we move on to the more interesting calculations we will be discussing in this chapter, we need to determine how many points it is possible for each student to earn for each of the assignments. This information will go into Row 25. The =MAX function is our tool of choice.
Download Data File: CH3 Data
By default, the calculations that Excel copies change their cell references relative to the row or column you copy them to. That makes sense. You wouldn’t want column N to display an answer that uses the values in column L.
Want to see all the calculations you have just created? Press Ctrl ~ (See Figure 3.3.) Ctrl ~ displays your calculations (formulas). Pressing Ctrl ~ a second time will display your calculations in the default view – as values.
The Quick Analysis Tool allows you to create standard calculations, formatting, and charts very quickly. In this exercise we will use it to insert the Total Points for each student in Column O.
Be sure to press Ctrl ~ to return your spreadsheet to the normal view (the formula results should display, not the formulas themselves).
Column P requires a Percentage calculation. Before we launch in to creating a calculation for this, it might be handy to know precisely what it is we are looking for. If you are connected to the internet, and are using Excel 2016, you can use the Smart Lookup tool to get some more information.
I think the first Wikipedia article does a pretty good job explaining the calculation, don’t you?
Now that we know what is needed for the Percentage calculation, we can have Excel do the calculation for us. We need to divide the Total Points for each student by the Total Points of all the Points Possible. Notice that there is a different number on each row – for each student. But, there is only one Total Points Possible – the value that is in cell O25.
Before copying the calculation, we have to make the second reference (O25) an absolute cell reference. That way, when we copy the formula down, the cell reference for O25 will be locked and will not change.
Those long decimals are a bit nonstandard. Let’s change them to % by applying cell formatting.
Skill Refresher
Absolute References
- Click in front of the column letter of a cell reference in a formula or function that you do not want altered when the formula or function is pasted into a new cell location.
- Press the F4 key or type a dollar sign ($) in front of the column letter and row number of the cell reference.
Key Takeaways
- Functions can be created using cell ranges or selected cell locations separated by commas. Make sure you use a cell range (two cell locations separated by a colon) when applying a statistical function to a contiguous range of cells.
- To prevent Excel from changing the cell references in a formula or function when they are pasted to a new cell location, you must use an absolute reference. You can do this by placing a dollar sign ($) in front of the column letter and row number of a cell reference or by using the F4 function key.
- The #DIV/0 error appears if you create a formula that attempts to divide a constant or the value in a cell reference by zero.
3.1 More on Formulas and Functions by Noreen Brown and Mary Schatz, Portland Community College, is licensed under CC BY 4.0
Learning Objectives
- Use and IF Function to make logical comparisons between a value and what you expect.
- Create a VLOOKUP calculation to look up information in a table.
- Understand error messages.
- Understand how to enter and format Date/Time Functions.
In addition to doing arithmetic, Excel can do other kinds of functions based on the data in your spreadsheet. In this section we will use an =IF function to determine whether a student is passing or failing the class. Then, we will use a =VLOOKUP function to determine what grade each student has earned.
The IF function is one of the most popular functions in Excel. It allows you to make logical comparisons between a value and what you expect. In its simplest form, the IF function says something like:
If the value in a cell is what you expect (true) – do this. If not – do that.
The IF function has three arguments:
In column Q we would like Excel to tell us whether a student is passing – or failing the class. If the student scores 70% or better, he/she will pass the class. But, if he/she scores less than 70%, he/she is failing.
Now you will see the IF Function dialog box, with a place to enter each of the three arguments.
While we are here, let’s take a look at the dialog box. Notice that as you click in each box, Excel gives you a brief explanation of the contents (in the middle below the boxes.) In the lower left hand corner, you can see the results of the calculation. In this case DeShae is passing the class. Below that is a link to Help on this function. Selecting this link will take you to the Excel help for this function – with detailed information on how it works.
You need to use a VLOOKUP function to look up information in a table. Sometimes that table is on a different sheet in your workbook. Sometimes it is in another file entirely. In this case, we need to know what grade each student is getting based on their percentage score. You will find the table that defines the scores and the grades in A28:B32.
There are four pieces of information that you will need in order to build the VLOOKUP syntax. These are the four arguments of a VLOOKUP function:
Let’s create the VLOOKUP to display the correct Letter Grade in column R.
Note: What if it didn’t work? What if you get a result different from the one predicted? In this case, either you have made a previous error, resulting in different % scores than this exercise anticipated, or you made a mistake entering your VLOOKUP function.
To make repairs in the function, make sure that R5 is your active cell. On the Formula bar, press the Insert Function button (see Figure 3.15). That will reopen the dialog box so you can make your repairs. Did you forget to make the cell references for the Table_array absolute? Did you use the wrong cell for the Lookup_value? Press OK when you are done and recopy the corrected function.
Sometimes Excel notices that you have made errors in your calculations before you do. In those cases Excel alerts you with some slightly mysterious error messages. A list of common error messages can be found in Table 3.1 below.
Table 3.1 – Common Error Messages
Message | What Went Wrong |
#DIV/0! | You tried to divide a number by a zero (0) or an empty cell. |
#NAME | You used a cell range name in the formula, but the name isn’t defined. Sometimes this error occurs because you type the name incorrectly. |
#N/A | The formula refers to an empty cell, so no data is available for computing the formula. Sometimes people enter N/A in a cell as a placeholder to signal the fact that data isn’t entered yet. Revise the formula or enter a number or formula in the empty cells. |
#NULL | The formula refers to a cell range that Excel can’t understand. Make sure that the range is entered correctly. |
#NUM | An argument you use in your formula is invalid. |
#REF | The cell or range of cells that the formula refers to aren’t there. |
#VALUE | The formula includes a function that was used incorrectly, takes an invalid argument, or is misspelled. Make sure that the function uses the right argument and is spelled correctly. |
This table was copied from the internet. Look here for additional information.
http://www.dummies.com/software/microsoft-office/excel/how-to-detect-and-correct-formula-errors-in-excel-2016/
Very often dates and times are an important part of Excel data. Numbers that are correct today may not be accurate tomorrow. So, it is frequently useful to include dates and times on your spreadsheets.
These dates and times fall into two categories – ones that:
Take a look at the list of Date and Time functions offered in the Function Library on the Formulas tab (see Figure 3.16).
For our gradebook, we want the date and time to be displayed in A2, and it needs to update whenever the workbook file is opened.
Excel will update this field independently whenever you save and re-open the file, or print it. It may happen more frequently than that – depending on how you have set this up in your installation of Excel.
Another variation of the current date is the TODAY function. Let’s try that one next.
Keyboard Shortcuts
Sometimes you want the date or the time to show up in your spreadsheet, but you don’t want it to change. You can simply type in the date or time. Or, you can use shortcut keys.
- CTRL; (semi colon) will bring you the current date
- CTRL: (colon or CTRL SHIFT ; ) will bring you the current time.
Key Takeaways
- Functions don’t always have to be about arithmetic. Excel provides functions that will help you perform logical evaluations, look things up, and work with dates and times.
- Excel displays error messages when your formulas and functions are not constructed properly.
3.2 Logical and Lookup Functions by Noreen Brown and Mary Schatz, Portland Community College, is licensed under CC BY 4.0
Learning Objectives
- Use Conditional Formatting techniques to provide flexible highlighting, applying specified formatting only when certain conditions are met. Techniques include:
- Data bars — to make it easy to visualize values in a range of cells.
- Cells Rules — to highlight values that match the requirements you specify.
You now have all the calculations you need in your CAS 170 Grades spreadsheet. There is a lot of data here. To make it easier to pick out the most important pieces of data, Excel provides Conditional Formatting. The best thing about Conditional Formatting is that it is flexible, applying specified formatting only when certain conditions are met.
Excel places blue bars on top of your values; long blue bars for larger numbers, shorter ones for smaller numbers. This makes it easier to see how well each student did in the class – without having to look at the specific numbers.
Another way to apply Data Bars is to:
Let’s try that one more time – to highlight those students who are passing the class. This time we will use the Pass/Fail text in the Pass/Fail column. If the text for a student is Pass we want the cell to be formatted with a yellow fill with dark yellow text.
You do not have to use the default styles to make your data stand out. You can set any formatting you want. When you do, it is probably a good idea to include other styling in addition to color. Your spreadsheet might be printed in black and white. You would hate to lose your Conditional formatting. Now we are going to use conditional formatting to display any Percentages that are less than 60% with red text formatted in bold and italic.
Conditional Formatting is valuable in that it reflects the current data. It changes to reflect changes in the data. To test this, delete DeShea’s final exam score. (Select N5. Press Delete on your keyboard.) Suddenly, DeShae is failing the course and the Conditional Formatting reflects that. This is a little unfair to DeShae – who has worked so hard this quarter. Let’s give him back his grade. Press CTRL Z (Undo). His test score reappears and the Conditional formatting reflects that as well.
What if you have made a mistake with your Conditional Formatting? Or, you want to delete it altogether? You can use the Conditional Formatting Manage Rules tool. In our example, we want to remove the conditional formatting rule that formats the Pass text with yellow. We are also going to modify the minimum passing percentage for the conditional formatting rule that is applied to the percentages.
In a previous exercise (the IF function), we decided that students were failing if they got a percentage score of less than 70%, so the Conditional Formatting rule in the Percentage column needs repair.
Before you consider this workbook finished, you need to prepare it for printing. The first thing you will do is set the Print Area so that the table of Letter Grades in A27:B32 does not print.
Next you will preview the worksheet in Print Preview to check that the print area setting worked, as well as make sure it is printing on one page.
3.3 Conditional Formatting by Noreen Brown and Mary Schatz, Portland Community College, is licensed under CC BY 4.0
Learning Objectives
- Locate and fix formatting consistency errors.
- Apply new formatting techniques.
- Use Print Titles to repeat rows and columns on each page of a multiple page worksheet.
- Control where page breaks occur in a multiple page worksheet.
In this section, we will review a worksheet for formatting consistency, as well as learn two new formatting techniques. This worksheet currently prints on four pages, so we will learn new page setup options to control how these pages print. A new data file will be used for this section.
Download Data File: CH3 PTP Data
You have been given a workbook with data about the national parks in the western United States. Your coworker formatted the workbook and has asked you to review it for consistency. You also need to prepare it for printing. Figure 3.26 shows how the second page of the finished worksheet will appear in Print Preview.
The first thing you are going to do is review the worksheet for formatting inconsistencies.
Now that you have fixed the inconsistencies in the formatting, you decide to apply some formatting techniques to make the worksheet look even better. You are going to start by vertically aligning the names of the states within the cells.
The next new formatting skill is to change the label in E3 from Size (km2) to Size (km2) with the 2 after km formatted with superscript.
Now that you have fixed the cell and text formatting, you are ready to review the worksheet in Print Preview. You will notice that the worksheet is printing on multiple pages, and you cannot tell what each column of data represents on some of the pages.
You will not see a change to the worksheet in Normal view, so you will need to return to Print Preview. While looking in Print Preview, you will notice that the pages are breaking in inconvenient places.
Skill Refresher
Creating Print Titles
- Open the Page Setup dialog box and click the Sheet tab.
- Click in the Rows to repeat at top: box or the Columns to repeat at left: box.
- Click in the worksheet and select the row(s) or column(s) that you want to repeat on each page.
Notice that the data for California is split between the first and second pages. You want all of the data for each state to be together on the same page, so you need to control the page breaks. You are going to start by inserting a page break before the California data to force it to start on the second page, then you will move the page break for the third page if needed. To make these changes you are going to work in Page Break Preview.
In Page Break Preview, automatic page breaks are displayed as dotted blue lines. Notice the dotted blue lines after rows 19 and 35. These lines indicate where Excel will start a new page. For this worksheet, you want the first page to break before the California data, so you are going to insert a manual page break.
While looking at each page in Print Preview you decide that the third page should start with Montana. To make this change you are going to move the automatic page break that appears after Nevada.
While evaluating the pages in Print Preview you decide that there is too much white space at the bottom of the pages. To fix this, you are going to center the contents vertically on the pages.
Now that the worksheet is printing on three pages, with page breaks in appropriate places, you are ready to add a header with the current date and filename. You will also add a footer with the page number and the total number of pages that will appear as Page 1 of 3. You are going to edit the header and footer in Page Layout View.
Skill Refresher
Inserting Page Numbers
- In Page Layout View, click in the section of the header or footer where you want the page number to appear.
- Type the word Page, followed by a space, and then click the Page Number button in the Header & Footer Elements group on the Header & Footer Tools Design ribbon. This will create Page 1.
- If desired, type a space after the &[Page] code then type the word of followed by a space. Then click the Number of Pages button. This will create Page 1 of 4.
Key Takeaways
- Always check the formatting of your worksheets for consistency.
- If a worksheet is printing on multiple pages, use Print Titles to repeat rows at the top and/or columns at the left of every page to make it easier to interpret the data.
- Insert manual page breaks as needed in Page Break Preview to control where a new page begins.
- Multiple page worksheets should include the page number in either the header or footer. Be sure to insert the Page Number element so that the correct page number will display on each page of the worksheet.
“3.4 Preparing to Print” by Julie Romey, Portland Community College is licensed under CC BY 4.0
Download Data File: PR3 Data
Elijah and Kelly Williams are a recently married couple living in Portland, Oregon. Elijah works part time and attends the local community college. Kelly works as a marketing manager at a clothing company in North Portland. They are trying to decide if they can afford to move to a better apartment, one that is closer to work and school. They want to use Excel to examine their household budget. They have started their budget spreadsheet, but they need your help with it.
“3.5 Chapter Practice” by Diane Shingledecker, Portland Community College is licensed under CC BY 4.0, It is adapted from Personal Budget Project by Matt Goff, CC BY-SA 4.0.
Download Data File: SC3 Data
AstroCoffee: Cynthia McHenry owns a coffee supply company named AstroCoffee. She needs some help writing the formulas for the order form she uses to invoice customers. You will need to write the formulas for all of the calculations on the form. Some of the more complex parts are determining if the customer will get a discount (based on the customer status) as well as the shipping charge (orders over $200 get free shipping). You will use IF functions for both of those calculations.
Item # | Description | Qty | Unit Price |
K56 | Dark Mocha K-Cups (12 pack) | 1 | 10.99 |
G03 | Decaf Dark Roast – Ground (1 lb.) | 3 | 12.99 |
B07 | Dark Roast – Whole Bean (1 lb.) | 2 | 13.99 |
K52 | Chai Latte K-Cups (12 pack) | 3 | 12.99 |
“3.6 Chapter Scored” by Noreen Brown and Mary Schatz, Portland Community College is licensed under CC BY 4.0
Chapter 4 - Presenting Data with Charts
One of the most important things to consider when using charts in Excel is that they are intended to be used for communicating an idea to an audience. Your audience can be reading your charts in a written document or listening to you in a live presentation. In fact, Excel charts are often imported or pasted into Word documents or PowerPoint slides, which serve this very purpose of communicating ideas to an audience. Although there are no rules set in stone for using specific charts for certain data types, some chart types are designed to communicate certain messages better than others. This chapter explores numerous charts that can be used for a variety of purposes. In addition, we will examine formatting charts and using those charts in Word and PowerPoint documents.
Adapted by Noreen Brown from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
LEARNING OBJECTIVES
- Construct a line chart to show a time series trend.
- Learn how to adjust the Y axis scale.
- Construct a line chart to present a comparison of two trends.
- Learn how to use a column chart to show a frequency distribution.
- Create a separate chart sheet for a chart embedded in a worksheet.
- Construct a column chart that compares two frequency distributions.
- Learn how to use a pie chart to show the percent of total for a data set.
- Construct a stacked column chart to show how a percent of total changes over time.
This section reviews the most commonly used Excel chart types. To demonstrate the variety of chart types available in Excel, it is necessary to use a variety of data sets. This is necessary not only to demonstrate the construction of charts but also to explain how to choose the right type of chart given your data and the idea you intend to communicate.
Before we begin, let’s review a few key points you need to consider before creating any chart in Excel.
Integrity Check
Carefully Select Data When Creating a Chart
Just because you have data in a worksheet does not mean it must all be placed onto a chart. When creating a chart, it is common for only specific data points to be used. To determine what data should be used when creating a chart, you must first identify the message or idea that you want to communicate to an audience.
Table 4.1 Key Steps before Constructing an Excel Chart
Step | Description |
Define your message. | Identify the main idea you are trying to communicate to an audience. If there is no main point or important message that can be revealed by a chart, you might want to question the necessity of creating a chart. |
Identify the data you need. | Once you have a clear message, identify the data on a worksheet that you will need to construct a chart. In some cases, you may need to create formulas or consolidate items into broader categories. |
Select a chart type. | The type of chart you select will depend on the message you are communicating and the data you are using. |
Identify the values for the X and Y axes. | After you have selected a chart type, you may find that drawing a sketch is helpful in identifying which values should be on the X and Y axes. In Excel, the axes are: The “category” axis. Usually the horizontal axis – where the labels are found The “value” axis. Usually the vertical axis – where the numbers are found. |
The first chart we will demonstrate is a line chart. Figure 4.1 shows part of the data that will be used to create two line charts. This chart will show the trend of the NASDAQ stock index.
Read more: http://www.investopedia.com/terms/n/nasdaq.asp
This chart will be used to communicate a simple message: to show how the index has performed over a two-year period. We can use this chart in a presentation to show whether stock prices have been increasing, decreasing, or remaining constant over the designated period of time.
Before we create the line chart, it is important to identify why it is an appropriate chart type given the message we wish to communicate and the data we have. When presenting the trend for any data over a designated period of time, the most commonly used chart types are the line chart and the column chart. With the column chart, you are limited to a certain number of bars or data points. As you increase the number of bars on a column chart, it becomes increasingly difficult to read. As you scroll through the data on the worksheet shown in Figure 4.1 you will see that there are 24 points of data used to construct the chart. This is generally too many data points to put on a column chart, which is why we are using a line chart. Our line chart will show the volume of sales for the NASDAQ on the Y axis and the Month number on the X axis. The following steps explain how to construct this chart:
Download Data file: CH4 Data
This adds, or embeds, the line chart to the worksheet, as shown in Figure 4.3
Why?
Line Chart vs. Column Chart
We can use both a line chart and a column chart to illustrate a trend over time. However, a line chart is far more effective when there are many periods of time being measured. For example, if we are measuring fifty-two weeks, a column chart would require fifty-two bars. A general rule of thumb is to use a column chart when twenty bars or less are required. A column chart becomes difficult to read as the number of bars exceeds twenty.
Figure 4.3 shows the embedded line chart in the Stock Trend worksheet. Do you see where your labels showed up on the chart?
Notice that additional tabs, or contextual tabs, are added to the ribbon. We will demonstrate the commands in these tabs throughout this chapter. These tabs appear only when the chart is activated.
Note: Excel 2010 uses three contextual tabs for charts. Later versions use only two. Each has all the same tools. They are just organized a little differently.
As shown in Figure 4.3, the embedded chart is not placed in an ideal location on the worksheet since it is covering several cell locations that contain data. The following steps demonstrate common adjustments that are made when working with embedded charts:
Note: Keep an eye on your pointer. It will change intowhen you are in the right place to move your chart.
Note: keep an eye on your pointer. It will change intowhen you are in the right place to resize your chart
Figure 4.4 shows the line chart after it is moved and resized. You can also see that the title of the chart has been edited to read May 2014-2016 Trend for NASDAQ Sales Volume. Notice that the sizing handles do not appear around the perimeter of the chart. This is because the chart has been deactivated. To activate the chart, click anywhere inside the chart perimeter.
Figure 4.4 Line Chart Moved and Resized
Integrity Check
When using line charts in Excel, keep in mind that anything placed on the X axis is considered a descriptive label, not a numeric value. This is an example of a category axis. This is important because there will never be a change in the spacing of any items placed on the X axis of a line chart. If you need to create a chart using numeric data on the category axis, you will have to modify the chart. We will do that later in the chapter.
Skill Refresher
Inserting a Line Chart
- Highlight a range of cells that contain data that will be used to create the chart. Be sure to include labels in your selection.
- Click the Insert tab of the ribbon.
- Click the Line button in the Charts group.
- Select a format option from the Line Chart drop-down menu.
After creating an Excel chart, you may find it necessary to adjust the scale of the Y axis. Excel automatically sets the maximum value for the Y axis based on the data used to create the chart. The minimum value is usually set to zero. That is usually a good thing. However, depending on the data you are using to create the chart, setting the minimum value to zero can substantially minimize the graphical presentation of a trend. For example, the trend shown in Figure 4.4 appears to be increasing slightly in recent months. The presentation of this trend can be improved if the minimum value started at 500,000. The following steps explain how to make this adjustment to the Y axis:
Note: If you do not see “Format Axis . . . on your menu, you have not right clicked in the correct spot. Press “Escape” to turn the menu off and try again
![]()
Figure 4.5 Format Axis Pane
Figure 4.6 shows the change in the presentation of the trend line. Notice that with the Y axis starting at 500,000, the trend for the NASDAQ is more pronounced. This adjustment makes it easier for the audience to see the magnitude of the trend.
Skill Refresher
Adjusting the Y Axis Scale
- Click anywhere along the Y axis to activate it.
- Right Click.
(Note, you can also select the Format tab in the Chart Tools section of the ribbon.)- Select Format Axis . . .
- In the Format Axis pane, make your changes to the Axis Options.
- Click in the input box next to the desired axis option and then type the new scale value.
- Click the Close button at the top right of the Format Axis pane to close it.
We will now create a second line chart using the data in the Stock Trend worksheet. The purpose of this chart is to compare two trends: the change in volume for the NASDAQ and the change in the Closing price.
Before creating the chart to compare the NASDAQ volume and sales price, it is important to review the data in the range B4:D28 on the Stock Trend worksheet. We cannot use the volume of sales and the closing price because the values are not comparable. That is, the closing price is in a range of $45.00 to $115.00, but the data for the volume of Sales is in a range of 684,000 to 3,711,000. If we used these values – without making changes to the chart — we would not be able to see the closing price at all.
The construction of this second line chart will be similar to the first line chart. The X axis will be the months in the range B4:D28.
Figure 4.6.5 shows the appearance of the line chart comparing both the volume and the closing price before it is moved and resized. Notice that the line for the closing price (Close) appears as a straight line at the bottom of the chart. Also, the chart is covering the data again, and the title needs to be changed.
![]()
Figure 4.6 Trend Comparison Line Chart
Note: The line representing the closing values is flat along the bottom of the chart. This is hard to see and not very useful as is. Fear not. We will fix that.
Good. But, we still cannot really see the Closing Price data. It is the flat red line at the very bottom of the chart.
Better! But, it would be nice to be able to see that the values on the right represent prices.
Figure 4.9 Final Comparison Line Chart
On the Stock Trend worksheet:
A column chart is commonly used to show trends over time, as long as the data are limited to approximately twenty points or less. A common use for column charts is frequency distributions. A frequency distribution shows the number of occurrences by established categories. For example, a common frequency distribution used in most academic institutions is a grade distribution. A grade distribution shows the number of students that achieve each level of a typical grading scale (A, A−, B+, B, etc.). The Grade Distribution worksheet contains final grades for some hypothetical Excel classes. To show the grade frequency distribution for all the Excel classes in that year, the numbers of students appear on the Y axis and the grade categories appear on the X axis. The number of students for this chart is in Column C. The labels for grades are in Column A. The following steps explain how to create this chart:
Figure 4.12 shows the completed grade frequency distribution chart. By looking at the chart, you can immediately see that the greatest number of students earned a final grade in the B+ to B− range.
![]()
Figure 4.12 Grade Frequency Distribution Chart
Why?
Column Chart vs. Bar Chart
When using charts to show frequency distributions, the difference between a column chart and a bar chart is really a matter of preference. Both are very effective in showing frequency distributions. However, if you are showing a trend over a period of time, a column chart is preferred over a bar chart. This is because a period of time is typically shown horizontally, with the oldest date on the far left and the newest date on the far right. Therefore, the descriptive categories for the chart would have to fall on the horizontal – or category axis, which is the configuration of a column chart. On a bar chart, the descriptive categories are displayed on the vertical axis.
Figure 4.14 shows the Final Grades for the all the Excel Classes column chart is in a separate chart sheet. Notice the new worksheet tab added to the workbook matches the New sheet name entered into the Move Chart dialog box. Since the chart is moved to a separate chart sheet, it no longer is displayed in the Grade Distribution worksheet.
![]()
Figure 4.14 Chart Sheet Added to the Workbook
We will create a second column chart to show a comparison between two frequency distributions. Column B on the Grade Distribution worksheet contains data showing the number of students who received grades within each category for the Spring Quarter. We will use a column chart to compare the grade distribution for Spring (Column B) with the overall grade distribution for the whole year (Column C).
However, since the number of students in the term is significantly different from the total number of students in the year, we must calculate percentages in order to make an effective comparison. The following steps explain how to calculate the percentages:
Figure 4.15 shows the completed percentages added to the Grade Distribution worksheet.
The column chart we are going to create uses the grade categories in the range A4:A8 on the X axis and the percentages in the range E4:F8 on the Y axis. This chart uses data that is not in a contiguous range, so we need to use the Ctrl key to select the ranges of cells.
![]()
Figure 4.16 Completed Data Series for the Class Grade Distribution
Figure 4.17 shows the final appearance of the column chart. The column chart is an appropriate type for this data because there are fewer than twenty data points and we can easily see the comparison for each category. An audience can quickly see that the class issued fewer As compared to the college. However, the class had more Bs and Cs compared with the college population.
Figure 4.17 Completed Grade Distribution Column Chart
Integrity Check
Too Many Bars on a Column Chart?
Although there is no specific limit for the number of bars you should use on a column chart, a general rule of thumb is twenty bars or less. Figure 4.18 contains a total of thirty-two bars. This is considered a poor use of a column chart because it is difficult to identify meaningful trends or comparisons. The data used to create this chart might be better used in two or three different column charts, each with a distinct idea or message.
The next chart we will demonstrate is a pie chart. A pie chart is used to show a percent of total for a data set at a specific point in time. The data we will use to demonstrate a pie chart is related to enrollment data for Portland Area Community Colleges for Fall of 2014. You will find that data on the Enrollment Statistics sheet.
Note: if you let go of the mouse button before dragging, you may only get one slice to move when you drag it out from the center. This can be another option for displaying your data. Use the Undo button to undo this if you want to try again.
![]()
Figure 4.20 Final Settings in the Format Data Labels Pane
Although there are no specific limits for the number of categories you can use on a pie chart, a good rule of thumb is ten or less. As the number of categories exceeds ten, it becomes more difficult to identify key categories that make up the majority of the total.
![]()
Figure 4.21 Final Enrollment Statistics Pie Chart
Skill Refresher
Inserting a Pie Chart
- Highlight a range of cells that contain the data you will use to create the chart.
- Click the Insert tab of the ribbon.
- Click the Pie button in the Charts group.
- Select a format option from the Pie Chart drop-down menu.
The last chart type we will demonstrate is the stacked column chart. We use a stacked column chart to show a percent of a total . For example, the data on the Enrollment Statistics worksheet shows student enrollment by race for several colleges. We would like to see all of the data on all of the colleges.
![]()
Figure 4.22 Selecting the 100% Stacked Column Chart
Figure 4.23 shows the column chart that is created after selecting the 100% Stacked Column format option. As mentioned, the goal of this chart is to show the enrollment of students by race. However, notice that Excel places the racial categories on the X axis. It would be more useful if the different colleges were there instead.
![]()
Figure 4.23 Initial Construction of the 100% Stacked Column Chart
The reason that Excel organized the data this way is that there are more Race/ethnicity categories (data in column A) than there are colleges (data in row 2). Not a bad guess. But, not what we wanted in this case.
The remaining steps explain how to correct this problem and complete the chart:
Figure 4.25 shows the final stacked column chart. Notice the similarities and differences in the enrollment at the local community colleges.
![]()
Figure 4.25 Final 100% Stacked Column Chart
Skill Refresher:
Inserting a Stacked Column Chart
- Highlight a range of cells that contain data that will be used to create the chart.
- Click the Insert tab of the ribbon.
- Click the Column button in the Charts group.
- Select the Stacked Column format option from the Column Chart drop-down menu to show the values of each category on the Y axis. Select the 100% Stacked Column option to show the percent of total for each category on the Y axis.
Key Takeaways
- Identifying the message you wish to convey to an audience is a critical first step in creating an Excel chart.
- Both a column chart and a line chart can be used to present a trend over a period of time. However, a line chart is preferred over a column chart when presenting data over long periods of time.
- The number of bars on a column chart should be limited to approximately twenty bars or less.
- When creating a chart to compare trends, the values for each data series must be within a reasonable range. If there is a wide variance between the values in the two data series (two times or more), the percent change should be calculated with respect to the first data point for each series.
- When working with frequency distributions, the use of a column chart or a bar chart is a matter of preference. However, a column chart is preferred when working with a trend over a period of time.
- A pie chart is used to present the percent of total for a data set.
- A stacked column chart is used to show how a percent total changes over time.
Adapted by Noreen Brown from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Apply formatting commands to the X and Y axes.
- Enhance the visual appearance of the chart title and chart legend by using various formatting techniques.
- Assign titles to the X and Y axes that clarify labels and numeric values for the reader.
- Apply labels and formatting techniques to the data series in the plot area of a chart.
- Apply formatting commands to the chart area and the plot area of a chart.
- Employ series lines and annotations to enhance trends and provide additional information on a chart.
You can use a variety of formatting techniques to enhance the appearance of a chart once you have created it. Formatting commands are applied to a chart for the same reason they are applied to a worksheet: they make the chart easier to read. However, formatting techniques also help you qualify and explain the data in a chart. For example, you can add footnotes explaining the data source as well as notes that clarify the type of numbers being presented (i.e., if the numbers in a chart are truncated, you can state whether they are in thousands, millions, etc.). These notes are also helpful in answering questions if you are using charts in a live presentation. We will demonstrate these formatting techniques using the column chart and stacked column chart from the previous section.
There are numerous formatting commands we can apply to the X and Y axes of a chart. Although adjusting the font size, style, and color are common, many more options are available through the Format Axis pane. The following steps demonstrate a few of these formatting techniques on the Grade Distribution Comparison chart:
Figure 4.26 Font Dialog Box
![]()
Figure 4.27 Formatted X and Y Axes
Next we want to make some changes to the percentage numbers on the Y (vertical) axis.
![]()
Figure 4.28 Format Axis Pane changes
Note: Experiment! You can also change font styling using shortcut keys and the buttons on the Home tab.
Skill Refresher
Formatting the X and Y Axes
- Click anywhere along the X or Y axis to activate it.
- Click either the Home tab or Design tab of the ribbon.
- Select any of the available formatting commands in these tabs.
Skill Refresher
X and Y Axis Number Formats
- Click anywhere along the X or Y axis to activate it.
- Click the Layout tab in the Chart Tools section of the ribbon.
- Click the Format Selection button in the Current Selection group of commands.
- Click Number from the list of options on the left side of the Format Axis dialog box.
- Select a number format and set decimal places on the right side of the Format Axis dialog box.
- Click the Close button in the Format Axis pane.
The next items we will format on the Grade Distribution Comparison chart are the chart legend and title. Similar to the how we formatted the X and Y axes, we can format these items by activating them and using the formatting commands in the Home tab or the Format pane. The following steps explain how to add these formats:
Skill Refresher
Formatting the Chart Legend
- Click the Legend to activate it.
- Click either the Home tab or right click to activate the appropriate formatting pane.
- Select any of the available formatting commands.
- Click and drag the legend to move it.
- Click and drag any of the sizing handles to adjust the size of the legend.
Skill Refresher
Formatting the Chart Title
- Click anywhere on the chart title.
- Click either the Home tab or right click to activate the appropriate formatting pane.
- Select any of the available formatting commands.
Titles for the X and Y axes are necessary for defining the numbers and categories presented on a chart. For example, by looking at the Grade Distribution Comparison chart, it is not clear what the percentages along the Y axis represent. The following steps explain how to add titles to the X and Y axes to define these numbers and categories:
Next we will add the title for the X axis.
Skill Refresher
X and Y Axis Titles
- On the Design tab select the Add Chart Element button.
- Click anywhere on the chart to activate it.
- Select one of the options from the second drop-down list.
- Click in the axis title to remove the generic title and type a new title.
Adding labels to the data series of a chart is a key formatting feature. A data series is the item that is being displayed graphically on a chart. For example, the blue bars on the Grade Distribution Comparison chart represent one data series. We can add labels at the end of each bar to show the exact percentage the bar represents. In addition, we can add other formatting enhancements to the data series, such as changing the color of the bars or adding an effect. The following steps explain how to add these labels and formats to the chart:
Now we are going to add the Data Labels at the end of the columns.
Figure 4.37 shows the Grade Distribution Comparison chart with the completed formatting adjustments and labels added to the data series. Note that we can move each individual data label. This might be necessary if two data labels overlap or if a data label falls in the middle of a grid line. To move an individual data label, click it twice, then click and drag.
Skill Refresher:
Ad d ing D a t a Labels
- Click anywhere on the chart to activate it.
- Click the Design tab in the Chart Tools section of the ribbon.
- Click the Add Chart Element in the Chart Layout group.
- Then, select Data Labels
- Select one of the preset positions from the drop-down list.
Skill Refresher
F o r m a tt ing a D a t a Se r ies
- Click any bar or line for a data series.
- Right click to activate the Format Data Series pane.
- Use the formatting tools in the pane to make changes to the data series.
The last formatting features we will demonstrate are adding series lines and annotations to a chart. To demonstrate these skills, we will use the Change in Enrollment Statistics Spend Source stacked column chart. Series lines are commonly used in stacked column charts to show the change from one stack to the next. Annotations are useful for clarifying the data presented in a chart or for identifying data sources. In addition to demonstrating these skills, we will review several of the formatting skills that were covered in this section. The following steps include the skills review as well as the new formatting features:
Figure 4.39 shows the appearance of the chart with the series lines connecting the two stacks. This formatting enhancement is common for stacked column charts. The lines help focus the audience’s attention to changes in the percent of total trend.
Our chart demonstrates the percentage differences in enrollment between the community colleges. But, it would be handy to know the total Enrollment at each of the colleges. To display that, we will add text boxes above each column. To start with, we need to make room for the text boxes.
Figure 4.41 Completed Stacked Column Chart
Integrity Check
Annotations and Axis Titles
Although adding annotations and axis titles can be a tedious process, doing so maintains a high level of integrity for your charts. People can misinterpret the message being conveyed by the chart if they make inaccurate assumptions about the values displayed. Axis titles and annotations help prevent readers from making false assumptions and ensure that readers see the most accurate representation of the message being conveyed by the chart.
Skill Refresher
Ad d ing Series Lines
- Click anywhere on the chart area.
- Click the Layout tab of the ribbon.
- Click the Lines button in the Analysis group of commands.
- Click the Series Lines option from the drop-down list.
Skill Refresher:
Ad d ing Anno t ations
- Click anywhere on the chart area.
- Click the Insert tab of the ribbon.
- Click the Text Box button in the Text group of commands.
- Click and drag the size of the text box needed on the chart.
- Apply any desired format changes from the Home tab of the ribbon.
- Type the desired text.
Key Takeaways
- Applying appropriate formatting techniques is critical for making a chart easier to read.
- Many formatting commands in the Home tab of the ribbon can be applied to a chart.
- To change the number format for a data label, you must use the Number section in the Format Data Labels dialog box. You cannot use the Number format commands in the Home tab of the ribbon.
- To change the number format for the values on the Y axis, and the X axis in the case of a scatter chart, you must use the Number section of the Format Axis dialog box. You cannot use the Number format commands in the Home tab of the ribbon.
- Axis titles and annotations help prevent false assumptions from being made and ensure that the reader sees the most accurate representation of the information presented on a chart.
Adapted by Noreen Brown from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Learn how to paste an image of an Excel chart into a Word document.
- Learn how to paste a link to an Excel chart into a PowerPoint slide.
Charts that are created in Excel are commonly used in Microsoft Word documents or for presentations that use Microsoft PowerPoint slides. Excel provides options for pasting an image of a chart into either a Word document or a PowerPoint slide. You can also establish a link to your Excel charts so that if you change the data in your Excel file, it is automatically reflected in your Word or PowerPoint files. We will demonstrate both methods in this section.
For this exercise you will need two files:
Excel charts can be valuable tools for explaining quantitative data in a written report. Reports that address business plans, public policies, budgets, and so on all involve quantitative data. For this example, we will assume that the Change in Enrollment Statistics Spend Source stacked column chart is being used in a student’s written report (see Figure 4.44). The following steps demonstrate how to paste an image, or picture, of this chart into a Word document:
Figure 4.42 Paste Picture in Word
Oh no!! The picture is so big that it falls on to the next page. We will need to change its size.
Figure 4.43 Changing the Size of a Picture in Word
Figure 4.44 shows the final appearance of the Enrollment by Race Source chart pasted into a Word document. It is best to use either the Shape Width or Shape Height buttons to reduce the size of the chart. Using either button automatically reduces the height and width of the chart in proper proportion. If you choose to use the sizing handles to resize the chart, holding the SHIFT key while clicking and dragging on a corner sizing handle will also keep the chart in proper proportion.
Figure 4.44 Final Appearance of Pasting a Chart Image into Word
Skill Refresher
P a sting a C h art I m a g e i n t o W o rd
- Activate an Excel chart and click the Copy button in the Home tab of the ribbon.
- Click on the location in the Word document where the Excel chart will be pasted.
- Click the down arrow of the Paste button in the Home tab of the ribbon.
- Click the Picture option from the drop-down list.
- Click the Format tab in the Picture Tools section of the ribbon.
- Resize the picture by clicking the up or down arrow on the Shape Width or Shape Height buttons.
For this exercise you will need two files:
Microsoft PowerPoint is perhaps the most commonly used tool for delivering live presentations. The charts used in a live presentation are critical for efficiently delivering your ideas to an audience. Similar to written documents, a wide range of presentations may require the explanation of quantitative data. This demonstration includes a PowerPoint slide that could be used in a presentation. We will paste the Enrollment by Race chart into this PowerPoint slide. However, instead of pasting an image, as demonstrated in the Word document, we will establish a link to the Excel file. As a result, if we change the chart in the Excel file, the change will be reflected in the PowerPoint file. The following steps explain how to accomplish this:
Next we need to make some changes to clean up the chart a bit. First, we are going to apply a different chart style.
Figure 4.46 Modifying and Excel Chart Pasted into a PowerPoint Slide
Paste linking this chart caused trouble with the text boxes we added, so next we are going to delete them.
The benefit of adding this chart to the presentation as a link is that it will automatically update when you change the data in the linked spreadsheet file.
Figure 4.47 shows the appearance of the column chart after the change was made in the Enrollment Statistics worksheet in the Excel file. Note that the Data Chart at the bottom reflects the new number, too. The change that was made in the Excel file will appear in the PowerPoint file after clicking the Refresh Data button.
Integrity Check
Refreshing Linked Charts in PowerPoint and Word
When creating a link to a chart in Word or PowerPoint, you must refresh the data if you make any changes in the Excel workbook. This is especially true if you make changes in the Excel file prior to opening the Word or PowerPoint file that contains a link to a chart. To refresh the chart, make sure it is activated, then click the Refresh Data button in the Design tab of the ribbon. Forgetting this step can result in old or erroneous data being displayed on the chart.
Integrity Check
Severed Link?
When creating a link to an Excel chart in Word or PowerPoint, you must keep the Excel workbook in its original location on your computer or network. If you move or delete the Excel workbook, you will get an error message when you try to update the link in your Word or PowerPoint file. You will also get an error if the Excel workbook is saved on a network drive that your computer cannot access. These errors occur because the link to the Excel workbook has been severed. Therefore, if you know in advance that you will be using a USB drive to pull up your documents or presentation, move the Excel workbook to your USB drive before you establish the link in your Word or PowerPoint file.
Skill Refresher:
P a sting a Linked C hart Image in t o P o w er P oint
- Activate an Excel chart and click the Copy button in the Home tab of the ribbon.
- Click in the PowerPoint slide where the Excel chart will be pasted.
- Click the down arrow of the Paste button in the Home tab of the ribbon.
- Click the Keep Source Formatting & Link Data option from the drop-down list.
- Click the Refresh Data button in the Design tab of the ribbon to ensure any changes in the Excel file are reflected in the chart.
Key Takeaways
- When pasting an image of an Excel chart into a Word document or PowerPoint file, use the Picture option from the Paste drop-down list of options – if you want the image to act as an image. You will not be able to make any changes to the content of the picture.
- When creating a link to a chart in Word or PowerPoint, you may need to refresh the data if you make any changes in the originating spreadsheet. You should not use the Picture option.
Adapted by Noreen Brown from How to Use Microsoft Excel: The Careers in Practice Series, adapted by The Saylor Foundation without attribution as requested by the work’s original creator or licensee, and licensed under CC BY-NC-SA 3.0.
Learning Objectives
- Review each worksheet in a workbook in Print Preview.
- Modify worksheets as needed to professionally print data and charts.
In this section we will take a look at each of the worksheets created in the previous sections. Since these worksheets contain a combination of data and charts, there are specific things to watch for if you will be printing the sheets.
We will start by looking at each worksheet in Print Preview in Backstage View. We will then make any changes necessary, such as changing the orientation and scaling, or moving charts around on the worksheet. To make sure we don’t miss any worksheets, we are going to review the worksheets in the order they appear in the tabs.
Data file: Continue with CH4 Charting.
The first worksheet, Closing Prices, is a chart sheet. This means that it does not contain any data; remember that chart sheets just contain charts. We still need to review it in Print Preview.
The next worksheet (Stock Trend) has a lot of data and multiple charts. We need to print the data and the charts, which will require some modifications of the page setup.
The first thing we are going to do is remove the numbers that are appearing on page 7. To do this, we will hide the column where they are being stored. We are going to hide the column, instead of deleting the numbers, in case the numbers are being utilized somewhere else in the workbook.
The data is still split between pages 2 and 3, and the charts are splitting oddly as well. The first step we will try to fix these issues is to change the page orientation and scaling.
The next thing we will try is moving one, or both, of the charts. In order to move the charts, we need to exit out of Backstage View.
We don’t want the data source link text to print on its own page, but there is no room to move it onto the same page as the charts. To fix this, we are going to remove the automatic page break between the charts and the text in M31:M32.
Now you need to do one final check of this worksheet in Print Preview.
There are four remaining worksheets to be reviewed. Some of them will need minor changes and some will not need any changes. You will need to preview each one and then make the specified changes. In the following steps you will preview and modify the next three worksheets.
Sometimes you might have a worksheet that has data and a chart, but you only want the chart to print. That is the case with the Enrollment Statistics worksheet.
You have actually decided that you do not want the Enrollment by Race Chart sheet to be visible at all, but you do not want to delete it. We are going to hide it from anyone looking at the workbook.
“4.4 Preparing to Print” by Julie Romey, Portland Community College is licensed under CC BY 4.0
To assess your understanding of the material covered in the chapter, please complete the following assignments.
Although Excel is primarily used in business and scientific applications, you will find it useful in other areas of study as well. In these exercises we will use Excel to create charts using historical, health, and social justice data.
Download Data File: PR4 Data
Excel is an excellent tool for helping to display historical date. In this exercise we will be examining ways to display information on minimum mage data and life expectancy.
Since the beginning of the previous century, the United States has set a minimum wage, in order to set a “floor” beneath which wages cannot fall. Most states have set their own minimum wages, but none are lower than the national minimum wage. To learn more about the national minimum wage, look here: https://en.wikipedia.org/wiki/Minimum_wage_in_the_United_States
In the past 40 years, between 1970 and 2010, life expectancy for Oregon men improved by 8.7 years and for women by 5.5 years. Oregon’s life expectancy has remained slightly higher than the U.S. average. The life expectancy will continue to improve for both men and women. However, the gain for men has been outpacing the gain for women. Consequently, the difference between men’s and women’s life expectancies has continued to shrink.
https://www.oregon.gov/das/OEA/Documents/OR_pop_trend2012.pdf
The Legend Entries need to be corrected to fix the issue with the data series (columns). Also, the Horizontal Axis Labels are just a series of default numbers. They need to be the range that contains the years.
“4.5 Chapter Practice” by Noreen Brown, Portland Community College is licensed under CC BY 4.0
Download Data File: SC4 Data
Felony disenfranchisement is the exclusion from voting of people otherwise eligible to vote (known as disfranchisement) due to conviction of a criminal offense, usually restricted to the more serious class of crimes: felonies. Jurisdictions vary as to whether they make such disfranchisement permanent, or restore suffrage after a person has served a sentence, or completed parole or probation. Affected individuals suffer “collateral consequences” including loss of access to jobs, housing, and other facilities.
Opponents have argued that such disfranchisement restricts and conflicts with principles of universal suffrage. It can affect civic and communal participation in general.
https://en.wikipedia.org/wiki/Felony_disenfranchisement
On the Disenfranchisement rate sheet, use the Recommended Chart tool to create the following three charts. Put each chart on its own individual sheet. (Note: Not an object in a spreadsheet.)
Chart1 — Felony Disenfranchisement Rate Washington
Notes
This is called a Clustered column chart in the Recommended charts tool, but it is really a combo chart – with some data displayed as columns and some data displayed as a line.
You will need to edit the Chart Title.
You may need to adjust the chart size to make it look like the illustration.
Put the chart on its own individual sheet — don’t leave it as an object on the spreadsheet.
Chart2 — Felony Disenfranchisement Rate Oregon
Notes:
Take a look at both the Washington and Oregon charts. They are the same kind of chart, but your charts may look different because the data is a bit different.To make them more similar – make sure that the vertical axes are the same in both charts. Format the left vertical (value) axis, so that the Maximum is 20000. Format the right vertical axis, so that the Maximum is .20.
Chart3 – Comparison – Oregon and Washington
Notes:
Be sure that you have years as labels on the horizontal axis (not 1, 2, 3 . . . )
This chart is on its own separate sheet.
“4.6 Scored Assessment” by Noreen Brown, Portland Community College is licensed under CC BY 4.0
Chapter 5 - Tables
Excel workbooks are designed to store lots of information. Organizing this information so that they display meaningful data can be challenging! Excel has many features that can help you organize your data and find what you need efficiently. Setting up your data as a table from the onset will allow you to sort, filter, total, and subtotal your data. In Excel, a table is a collection of data about a particular subject stored in adjacent rows and columns. Tables can improve the look and feel of your workbook. This chapter explores how to best set up Excel tables, how to edit them, and then how to work with them effectively. These skills will be demonstrated in the context of a multi-sheet file that shows national average weather for two very different cities in the United States. Weather data is often voluminous and difficult to summarize since we collect weather data every hour of every day. Providing meaningful summaries of such data is a useful skill to have.The skills learned with this data can easily be transferred to data specific to your professional and personal needs.
Chapter 5 – Tables by Diane Shingledecker, Portland Community College is licensed under CC BY 4.0
Learning Objectives
- Understand table structure.
- Plan, create, and edit a table.
- Freeze rows and columns.
- Sort data in a table.
This section reviews the fundamental skills for setting up and maintaining an Excel table. The objective used for this chapter is the construction of a multi-sheet file to keep track of two cities’ national weather data for the month of January. Organizing, maintaining, and reporting data are essentials skills for employees in most industries.
Figure 5.1 shows the completed workbook that will be demonstrated in this chapter. Notice that this workbook contains three worksheets. The first worksheet lists average weather for January in Portland, Maine. The second sheet lists average weather data for January in a very different climate – Portland, Oregon. The third sheet adds a weekly column to the Portland, Oregon data so that it can be subtotaled by week.
Download Data file: CH5 Data
When data is presented in long lists or columns, it helps if the table is set up well. Here are some rules of data-entry etiquette to follow when creating a table from scratch:
Following these rules will help insure that the sorts, filters, totals, and subtotals you apply to your table with give you the desired results.
With these rules in mind, we will begin working on the Portland ME worksheet in the National Weather workbook. Notice that the data is in adjacent columns and rows. The upper-left corner of the table is in A5 and the titles are above the column headings in Row 5. Since the set-up of our data looks good, we are ready to turn our data range into an Excel table:
After this, your spreadsheet will look like Figure 5.3.
Notice that a new ribbon tab, Table Tools Design, appears when you click inside your table. This ribbon tab allows you to edit, style, and add functionality to your table.
Let’s try these steps again in the following steps:
Skill Refresher
Create a Table
- Click on the top left cell in your data.
- Click the Table button in the Insert tab of the Ribbon.
- Make sure “My table has headers” is checked. Click OK.
- Click on the top left cell again.
- Adjust your columns widths so that you can see the complete headings with the filter arrows showing.
There are many ways to format an Excel table. There are preset colored Table Styles with Light, Medium, and Dark colors. There are also a variety of Table Style Options listed in Table 5.1.
Table 5.1 Table Style Options
Table Style | Description |
Header Row | Top row of the table that includes column headings |
Total Row | Row added to the bottom that applies column summary calculations |
First Column | Formatting added to the left-most column in the table |
Last Column | Formatting added to the right-most column in the table |
Banded Rows | Alternating rows of color added to make it easier to see rows of data |
Banded Columns | Alternating columns of color added to make it easier to see columns of data |
Filter Button | Button that appear at the top of each column that lists options for sorting and filtering |
We’ll add some formatting to both of our Portland weather tables in the following steps:
1. Click on the Portland ME sheet in your file.
2. In the Table Tools Design tab, in the Table Styles group, click the More button.
A gallery of table styles will appear as in Figure 5.4.
3. In the Table Styles gallery, in the Medium Section, click Table Style Medium 7.
4. In the Table Style Options group in the Ribbon, click Banded Rows.
The alternating colored rows will disappear. The data in the table is now more difficult to read.
5. Try out some of the other options in the Table Style Options group. Once you’re finished, check just Header Row, Banded Rows, and Filter Button as in Figure 5.5 below.
Over time, you will need to add new data to an Excel table. You will add the data to the table in a blank row. The easiest way to do this is to enter the data in the first blank row below the last row in the table. You can then rearrange the data in the table by sorting it. If you need to add data in a specific place in the middle of a table, you can insert a blank row in the middle and add your data there.
We need to add the last three days of the months to both our Portland, Maine and Portland, Oregon tables. The following steps will walk you through doing this.
Table 5.2 Portland, Maine data
Day | High (°F) | Low (°F) | Rain (inches) | Snow (inches) |
29 | 31.4 | 13.3 | 0.12 | 0.59 |
30 | 31.6 | 3.4 | 0.08 | 0.47 |
31 | 31.7 | 13.5 | 0.12 | 0.63 |
Notice that the banded row formatting continues as additional rows are added to the tables.
Table 5.3 Portland, Oregon data
Day | High (°F) | Low (°F) | Rain (inches) | Snow (inches) |
29 | 48.8 | 36.2 | 0.16 | 0 |
30 | 49.0 | 36.2 | 0.11 | 0.32 |
31 | 49.1 | 36.1 | 0.16 | 0 |
It is inevitable that you will find data errors in your table and need to correct them. While you can visually scan through a table to find your errors, this can be a tedious and tiresome process. Excel can help with this through the Find command. When you use Find, the best practice is to start at the top of the table to ensure that all your data is included in the search.
We know that a temperature of 3.4 degrees (brrr!) was entered erroneously in the Portland Maine sheet. It should have been 13.4. To fix this error, complete the following steps.
Skill Refresher
Finding and Replacing Data
- In the Home tab of the ribbon, click on Find & Select in the Editing Group and then click Find.
- In the Find box, type what you want to find, and then click Find Next.
- Continuing click Find Next until you find.what you are looking for.
- Click Close and edit your data.
When you freeze panes, Microsoft Excel keeps specific rows or columns visible in your table when you scroll through it on your screen. For example, if the first row in your spreadsheet contains labels, you might freeze that row to make sure that the column labels remain visible as you scroll down in your spreadsheet. When we scroll through our weather data, it would be nice to keep our column headings visible on the screen.
To freeze your headings:
Content in a table can be sorted alphabetically, numerically, and in many other ways. Sorting helps organize data by one or more columns in your table. Table 5.4 describes the different sort orders available for each column of data.
Table 5.4 Sort Options
Sort Order | Text | Numbers | Dates |
Ascending | Alphabetical (A-Z) | Smallest to Largest
Lowest to Highest | Chronological (oldest to newest) |
Descending | Reverse Alphabetical (Z-A) | Largest to Smallest
Highest to Lowest | Reverse Chronological (newest to oldest) |
Let’s say we want to know what the snowiest day was in January in Portland, Maine; so we want to sort the Snow column in Descending order so that the snowiest day ends up at the top of the table.
3. Now switch to the Portland Oregon sheet and repeat these sort steps to find the snowiest day in Oregon. Check your answers with Figure 5.10.
Figure 5.10 Snowiest Days in Oregon
Skill Refresher
Sort a Column
- Click on the filter Click arrow to the right of the header in the column you want to sort.
- Click on the choice AZ! or ZA↓ to sort your data by that column.
Sometimes you will need to sort your table by more than one column at a time in order to efficiently analyze your data. For example, if you were looking at several different types of loans from several bank offices, you would need to sort by the type of loan and then by bank office name to clearly see the different groups of loans. If you had a list of grades for students over their time in high school, you’d want to sort first by student name, but then also by grade level (freshman, sophomore, junior, and senior) so that each student’s grades would appear in chronological order.
For our weather data, let’s look at the snow days in Oregon and see how cold they were!
In most cases, we want our data sorted in “typical” sort order: numbers sorted highest to lowest, words sorted alphabetically, etc. Some data in our everyday lives; however, does not make sense when sorted this way. For example, if you sorted the days of the week alphabetically, you’d get: Friday, Monday, Saturday, Sunday, Thursday, Tuesday, and Wednesday. This order would be of no use to anyone! Similarly, the months of the year would not make sense alphabetically. Can you think of a number that would not make sense in either highest to lowest or lowest to highest order? (This is a good brain teaser!)
In our weather data, we’ve added a column for the week in the Weekly OR sheet and changed the days to Sunday through Saturday. This sheet lets us further analyze Portland, Oregon’s data to see if there are weekly trends in the weather. Let’s see if we can sort the Weekly OR sheet by Week and then by Day.
Key Takeaways
- Tables are made up of adjacent rows and columns of data with a single row of column headings at the top.
- You can create a table by clicking in the top left-most cell in your data and selecting Table in the Insert tab of the ribbon.
- There are a gallery of styles, as well as, style options to choose from to format a table.
- When you need to add data, it is best to add it one row below the bottom of the table. You can then sort to reorganize your data.
- Freezing heading keeps your column headings displayed while you scroll through your table data.
- You can use the filter arrows in the table headings to sort by a single column. Use Sort in the Data tab in the ribbon to sort by two or more columns at a time.
- Custom Sorts can be used when data needs to be sorted in a special way (i.e. – Days of the Week).
“5.1 Table Basics” by Diane Shingledecker, Portland Community College is licensed under CC BY 4.0
Learning Objectives
- Filter table data.
- Add a total row to a table.
- Insert subtotals into a table.
When you first create an Excel table, filter arrows appear in all the column headings. We have seen that you can use those arrows to sort your data by a single column. You can also use these same arrows to filter or limit the data you see by narrowing the displayed data within a column. There are many ways to filter data within a column depending on whether the data in the column is text or numeric. Table 5.5 gives you some filter examples:
Table 5.5 Filter Examples
Text Filters | |||
Desired Results | Filter Column | Text Filter | Checkbox Selected |
Data for the State of New Jersey (NJ) | State | Equals NJ | NJ |
Data for Books that Have Gardening in Their Title | Title | Contains Gardening | |
Data for Weather on the Weekend | Day | Equals Saturday OR equals Sunday | Saturday and Sunday |
Numeric Filters | |||
Desired Results | Filter Column | Number Filter | Checkbox Selected |
Data for Income Greater Than $1,000 | Income | Greater than 1,000 | |
Data for Amount Paid Equal to Zero | Amount Paid | Equals 0.00 | 0.00 |
Data for Mortgage and Auto Loans | Loan Type | Equals Mortgage OR equals Auto | Mortgage and Auto |
Notice there are sometimes more than one way to filter data (i.e. – with a filter choice or a checked box). There are also single criteria filters, as well as, multi-criteria filters. We will explore all of these next.
To start filtering, let’s look at just the first week of data in the Weekly OR sheet:
Your table should look like Figure 5.16. You should see only 7 rows of Week 1 data in your table. Notice in your Status Bar at the bottom of your screen the message “7 of 31 records found”. Also notice that the filter arrow in the Week heading has changed to a funnel which indicates that this column is currently filtered.
Skill Refresher
Filter a Column
- Click the filter arrow to the right of the heading in the column you want to filter.
- Click the Select All checkbox to deselect all of the checkbox choices.
- Click on the checkboxes you want to filter by.
- Click OK.
Un-Filter a Column
- Click the funnel to the right of the heading in the column you filtered.
- Select Clear filter.
You should see that it was only above 32 degrees three days in January in Maine – the first three! Check your table against Figure 5.18.
Figure 5.18 Filter Results
Let’s review sorting and filtering in the following steps:
Beginning in Excel 2013, slicers were added to the software as another way to filter your table data. A slicer is really useful because it clearly indicates what data is shown in your table after you filter your data.
Let’s try using the Slicer to filter our Portland OR data table:
By adding a total row to the bottom of your table, you can quickly see summary data for one or more of the columns in your table. Total rows can be added to tables as a whole, or those that are filtered. Total rows can easily be toggled on and off as the need for summary data arises.
Skill Refresher
Add a Total Row
- Click on the Total Row check box in the Table Style Options group in the Table Tools Design tab in the ribbon.
- Scroll to the bottom of your table to find the Total Row.
- Click in one of the columns in the Total Row, and then click the down-arrow that appears to the right of the cell.
- Choose Sum to add a sum to the Total Row in the column.
- To see the Average for column, click on the arrow again and choose Average.
Some other choices in the Total Row are Count (for words), Count Numbers, Max, and Min.
Skill Refresher
Add a Slicer
- Click on Insert Slicer in the Table Tools Design tab in the ribbon.
- Check the box for the column to which you want to add a Slicer.
- Click OK.
You can automatically calculate subtotals and grand totals in a table for a column. This is a powerful tool that allows you to quickly display multiple levels of summary data within your table. This can provide Management with a report of higher level summary data one minute, and then can be easily switched back to detailed data the next minute. It is important to save often during this process and follow the steps carefully. It is recommended that you make a copy of the data you want to subtotal and place it in a new sheet, so that you can save the summary subtotaled data separately if desired.
In order to subtotal successfully, you always need to do the following in order:
We want to find out what the weather looks like for each day of the week, so we’ll need to save our data to a new sheet, sort by the days of the week, and then convert the table in order to get ready to see the subtotal.
Your data should look like Figure 5.25. Successful subtotaling shows only one subtotal for each group in the column you sorted by. (HINT: If you end up with more than one Subtotal for the same group (i.e – one of the days of the week in our example), you did not sort before subtotaling. Remove your subtotals using the Remove All button in Figure 5.24, sort your table, and then try subtotaling again.)
Notice the three Outline buttons circled in the upper-left corner of the spreadsheet. These allow you to control the amount of subtotaled data that is displayed. Table 5.5 describes the different Outline buttons.
Table 5.5 Subtotal Outline Buttons
Button | Content Displayed |
Level 1 | Only grand total
|
Level 2 | Subtotals and grand total
|
Level 3 | Individual records, subtotals, and grand total |
Let’s try the three Outline buttons to see the difference in the data displayed:
Key Takeaways
- Filtering is an easy way to see a subset of your data. Filtering arrows appear to the right of each column heading when you insert a table with a header row.
- You can filter by text or numerically.
- A slicer is another way to filter in Excel that provides a set of filtering buttons on your sheet.
- Adding a total row to a table is a quick, efficient way to see summary statistics for one or more columns in a table.
- Subtotaling provides a way to quickly add totals to groups within a column along with providing a grand total at the bottom of the table.
- Subtotal Outline buttons allow users to see add of the subtotaled data, just the totals and grand total, or simply the grand total.
- Plus and minus buttons within subtotaling allow a user to expand and hide portions of the subtotaled data.
“5.2 Intermediate Table Skills” by Diane Shingledecker, Portland Community College is licensed under CC BY 4.0
Learning Objectives
- Review options for professional page setup for printing.
- Understand how to insert a picture to enhance the visual appearance of a worksheet.
- In this section, we will preview the worksheets containing tables to ensure they will print in a professional manner. We will make any formatting and page setup changes that are needed, as well as add a picture to one of the worksheets to enhance its appearance.
Data file: Continue with CH5 National Weather
Now that the weather data has been sorted, filtered, and subtotaled as needed, it is time to print the worksheets. You are going to start with the Portland ME worksheet.
Notice that cells A1, A2, and A3 are not merged and centered over the entire table of data. To fix this, you need to unmerge each of the merged cells, and then merge them again, making sure to include E1, E2, and E3 in the selection.
Next you need to preview the worksheet in Print Preview and determine what page setup options need to be set.
Notice that the table is to the far left of the page, with quite a bit of white space on the left. You decide that it would look better centered on the page.
Inserting an Image to Enhance a Worksheet
Next you are going to add a small weather related graphic to the worksheet to enhance its appearance. In Excel you can either insert an image file that you have saved or you can search for one online within Excel. In this example, there is a graphic saved in the data files for this chapter that you will use.
Figure 5.28 Insert Pictures
The image now appears on your worksheet, but not in the location you want. It is also slightly larger than you would like. (See Figure 5.29.) You are going to move the image to cell E1, then resize it so it does not cover up part of the table.
Before considering this workbook complete finished, you need to confirm that the remaining worksheets are all printing appropriately.
Notice that the last Slicer button (Saturday) is being cut off. This is because the Slicer height needs to be adjusted.
Key Takeaways
- When working with Excel workbooks, the final step should always be to review the worksheets in Print Preview to make sure they are printing appropriately.
- You can add images you have saved, or images you find online, to a worksheet to enhance its appearance. Be sure to resize and move them appropriately so they do not detract from the data.
“5.3 Preparing to Print” by Julie Romey, Portland Community College is licensed under CC BY 4.0
Download Data File: PR5 Data
Travel and tour companies need to keep track of client data, as well as, travel/tour options and tour guides. Keeping up-to-date, accurate records is essential to their bottom line. To run a tour company, employees must be able to manipulate their data quickly and easily. This exercise illustrates how to use the skills presented in this chapter to generate the data needed on a daily basis by a tourism company. See Figure 5.30 above.
“5.4 Chapter Practice” by Diane Shingledecker, Portland Community College is licensed under CC BY 4.0
“Canyon Trails Data File” by Matt Goff is licensed under CC BY 3.0
Download Data File: SC5 Data
Retail companies with today’s online, as well as, in-store sales have a lot of data to keep track of! Keeping track of sales, costs, and profits on a daily basis is essential to making the most of a business. This exercise illustrates how to use the skills presented in this chapter to generate the data needed on a daily basis by a retail company. See Figure 5.31 above.
“5.5 Scored Assessment” by Diane Shingledecker, Portland Community College is licensed under CC BY 4.0
Chapter 6 - Multiple Sheet Files
Excel workbooks often contain a large amount of data, and worksheets can quickly become overwhelming.When one worksheet becomes cumbersome, data can be broken out into smaller subsets and placed in separate worksheets within the same Excel file. Separating out spreadsheet data into smaller pieces can lead to better data organization within a file and increase its ease of use.When a retail company needs to track overall sales, as well as, individual store sales, it makes sense to place each store’s sales data in a separate sheet within a file. Adding a summary sheet that sums across all the sheets will allow for total company sales data in the same file! This chapter will show how to set up a workbook to make multi-sheet formulas quick and easy.
Other examples of when multiple sheets make the most sense are when you are comparing regional data, data for a salesforce and wish to evaluate individual salesperson performance along with overall sales, and data over a period of time where sheets can be broken out by year or by month. When comparing data across several sheets, it is essential that all the sheets are laid out in the same way. To facilitate this, a template can be used. A template is the basic pattern for each new sheet that can be used repeatedly to make sure each new sheet has the same setup, formatting, formulas, etc. as the existing sheets in a file. In this chapter, we will use both pre-made, Microsoft Excel templates, as well as, ones we will create from scratch to meet the specific needs of our work.
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Learning Objectives
- Navigating through a multiple sheet file.
- Adding, deleting, copying, and moving sheets.
- Grouping and ungrouping sheets.
Throughout our textbook, we have worked with Excel files that have included multiple sheets. Depending on the version of Excel you are using, a new Excel file starts with several sheets. In this chapter, we will be working with a personal budget file that contains income and expenses for an entire year. Our file contains a sheet for each month of the year, as well as, a Summary sheet that will add all twelve monthly sheets of data together. To begin with, we’ll get comfortable with moving through the sheets, organizing them, and making sure that all twelve monthly sheets are consistent.
Figure 6.1 shows the January sheet in the Personal Budget file along with all the sheet tabs along the bottom of the window.
Download Data file: CH6 Data
1. Open the data file CH6 Data and save the file to your computer as CH6 Personal Budget. Notice that the file has a Expenses Summary sheet at the far left followed by monthly sheets.
2. Click on the different sheets at the bottom of the screen to move through the sheets. Notice that the Expenses Summary sheet is formatted differently from the monthly sheets. Notice also that all the monthly sheets are identical in layout and format.
3. Take a second look at the months at the end of the year. Not all the data has been entered for September through October… and there is no sheet for December. We will enter the remaining data and add an additional sheet for December.
4. Add the following data in the September, October, and November sheets:
September | October | November | |
Power | $135 | $135 | $135 |
Water | $30 | $30 | $30 |
Groceries | $300 | $325 | $400 |
Miscellaneous | $100 | $50 | $100 |
Bonus | |||
Freelance | $500 | $150 | |
Other | $100 |
Next, we’ll update the November (2) sheet to turn it into our December sheet.
Skill Refresher
Copying a Sheet
- Point your mouse at the sheet you want to copy at the bottom of the screen.
- Hold down your left mouse button and then press and hold down the CTRL key.
- Drag your mouse to the right (still holding down the left-mouse button and the CTRL key) until the black down-pointing arrow is to the right of your existing sheet.
- Let go of the mouse button and then the CTRL key. You should now have a Sheetname (2) to the right of the original sheet.
- Rename the Sheetname (2) sheet as desired.
Sometimes your sheets do not end up in the right order, and you need to move them in order to fix this. Let’s try moving our “Practice” sheet to see how this is done.
Since our Practice sheet is not a sheet we will need in our Budget file, we’ll go ahead and delete it now.
Take a look at our monthly sheets again. Notice that there is a place in each of these sheets to calculate three pieces of Summary data: Income, Expenses, and Balance; but there aren’t any formulas in these cells. There is also a place for the % of Income Spent, but we need a formula in I6:I7 to calculate this. If we entered these formulas individually in each of the 12 month sheets, it would take a long time! Because this task would be very repetitive, it would also be fairly likely that we would make some mistakes along the way entering the same formulas over and over again. By grouping all the month sheets together, we can enter each of the formulas once and have them appear in all the sheets.
Now all 12 sheets should be selected. You can tell this in two ways: the sheet tabs that have been selected are now bold at the bottom of your screen. Notice in the Title bar at the top of the screen the word [Group] added to the end of the title. You can see both of these in Figure 6.4.
IT IS IMPORTANT TO REMEMBER THAT ANY CHANGES WE MAKE TO THE JANUARY SHEET WILL BE MADE TO ALL THE SHEETS!! This is a very good thing when we want to make changes to all the sheets at once, but we need to be sure to ungroup them when we’re done making these changes.Let’s go ahead and add the formulas to all twelve of the sheets at once:
Notice that a data bar was set up in I5 to visually show the income spent. Do you remember how to do this from earlier in our textbook? Your January sheet should now look like Figure 6.5.
7. Now that we are done making changes to all the monthly sheets at once, we need to ungroup them. Right-click on one of the grouped sheets and choose Ungroup Sheets.
Notice the sheets tabs are no longer bold and the word [Group] is no longer in the title bar.
8. Click on several of the month sheets to see that all the formulas have been added.
9. Click on the December sheet. Your sheet should now look like Figure 6.6.
Skill Refresher
To Group Sheets:
Click on the leftmost sheet you want to group; then hold the SHIFT key down and click on the rightmost sheet you want to group.To Ungroup Sheets:
Right-click on one of the grouped sheets and choose Ungroup Sheets.
Key Takeaways
- You can easily move, copy, delete, and rename sheets in your Excel file.
- Grouping sheets allows you to change a group of identically formatted sheets at the same time.
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Learning Objectives
- Entering formulas that reference another sheet.
- Using the SUM function to add up multiple sheets.
The Summary sheet in many multiple sheet workbooks is utilized to present totaled information from the other sheets in the file. This is done to give a quick synopsis of all the other sheets in one convenient location. For this reason, the Summary sheet is usually the first sheet in multiple sheet files. Summary sheets “pull” data from the other sheets using three-dimensional (3-D) cell references. In order to distinguish between A3 in the Summary sheet, A3 in the January sheet, A3 in the February sheet, etc.; a 3-D cell reference includes the sheet name along with the cell reference. The syntax to reference a cell in a different sheet is =SheetName!CellRange. So, the cell reference for A15 in the March sheet would be =March!A15.
Let’s start working on our summary sheet by trying out some 3-D formulas:
For the Annual Amounts in C5:C13 in the Expenses Summary sheet, we don’t need the amount from a single month’s sheets; instead, we need the sum of all the entries in all the monthly sheets. So, we need to sum three-dimensionally through all twelve month sheets. Here’s a helpful hint on the steps you need to follow to add through multiple sheets:
Skill Refresher
To SUM across sheets:
- Click on the cell where you want the 3-D SUM to appear.
- Type =SUM(
- Click on the leftmost sheet in the group of sheets you want to sum.
- Hold the SHIFT key down and click on the rightmost sheet in the group of sheets you want to sum.
- Click on the cell in the sheet you’re in that you want to sum.
- Press ENTER.
Let’s try adding up all the monthly amounts in our Expenses Summary sheet:
If you feel comfortable with these 3-D formulas, you can copy C6 down through C13 to fill in the rest of the formulas. If you’re not quite comfortable yet, keep practicing the above steps to add 3-D formulas to cells C7:C13. When you’re done, your Expenses Summary sheet should match Figure 6.7.
While our 3-D formulas are complete in the Expenses Summary sheet, our summary feels like it is lacking something. Let’s add a visual representation of our summary numbers to the sheet.
Figure 6.8 Completed Expenses Summary Sheet
Skill Refresher
3-D References in Formulas
To reference a cell in another sheet, use the formula syntax =SheetName!CellAddress.
To enter a 3-D reference:
- Click on the cell where you want the formula to appear and type =.
- Click on the sheet with the cell you want.
- Click on the cell in the sheet you want and press ENTER.
Key Takeaways
- 3-D references in formulas allow you to use data from one or more sheets on another sheet.
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Learning Objectives
- Use an existing Microsoft Excel template to create a new spreadsheet.
- Create a custom template to create new spreadsheets.
A template is a predefined pattern for a spreadsheet that has already been created for you. Hundreds of templates, already created by Microsoft, are available for you to use inside Excel. These templates are very helpful if you have limited time to get a new task done in Excel, and you don’t know where to start. Templates do a lot of the work for you! Templates include all the formulas, formatting, etc. needed in a professional Excel spreadsheet. All that’s left to do is enter the data. Predefined Microsoft templates include everything from billing statements to blood pressure trackers to business cards. Categories include: Business, Personal, Industry, Financial Management, Logs, Calculators, and Lists.
Sometimes you need a very specific template that hasn’t already been created by Microsoft. Taking the time to create your own template will allow you to use this spreadsheet pattern to create files from it over and over again. If you need to create a new version of a spreadsheet on a regular basis, templates will make this work much easier. In this chapter we will explore using existing Microsoft templates, as well as, creating our own templates.
Let’s start by trying out a predefined, Microsoft template:
Your screen should look like Figure 6.9 below. Notice the design, layout, and formulas have already been set up for you.
![]()
Figure 6.9 Travel Expenses Report Template
Try using the template by doing the following:
Skills Refresher
To use a Microsoft predefined template:
- Click on the File tab in the ribbon.
- Click on New
- Type the desired template description in the Search box, and press ENTER.
Now let’s shift to creating our own template. Sometimes you create a blank template first and then create spreadsheets from it. Other times, you have an existing spreadsheet that you realize you need a template for, so that you can recreate the file with new data over and over again. We’ll turn our existing CH6 Personal Budget file into a template now, and in the assignments at the end of the chapter, we’ll start templates from scratch before a filled-in spreadsheet is created.
NOTE: There are only formulas and the pie chart in the Expenses Summary sheet, so nothing needs to be deleted from this sheet to setup your template.
Skills Refresher
To save a file you created as a template:
- Click the File tab in the ribbon and then click Save As.
- Choose the location where you want to save the file.
- In the Save as type pull-down list, select Excel Template (*.xltx).
- At the top of the screen, double-check that the location you want to save the file to has not changed. If it has, use the pull-down list to find the location where you want to save your file. BE CAREFUL HERE! By default, Excel will try to save this to a default template file location on your hard drive.
- Type in the file name
- Click Save.
We are now going to use our new budget template to start a Personal Budget file for 2017. We want to use the Ch6 Personal Budget Template to create the new file, but we don’t want to overwrite the template. We want to keep it clean to use to start each new year’s file. To do this, we’ll save the file to our new 2017 file name before we start filling in any data.
Key Takeaways
- There are many pre-designed templates in Excel developed in Excel that you can use. This will save you the time and effort of designing and creating these files from scratch.
- You can create your own template files in Excel that you can use over and over again.
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Learning Objectives
- Printing all of the worksheets in a workbook at one time.
- Preparing multiple worksheets for printing using grouping.
Just like consistency in formatting is important when working with workbooks containing multiple worksheets with the same type of data, so is consistency in page setup. Now that the Personal Budget 2017 workbook is complete, you are going to prepare it for printing by changing the page orientation and adding a header. You will also print all 13 worksheets at one time.
Data file: Continue with CH6 2017 Personal Budget.
As always, you need to review your workbook in Print Preview before considering it complete. When you do that with this workbook, you notice that the worksheets are each printing on two pages. You decide to switch all the worksheets to Landscape orientation to see if that helps. You will also add a footer with the worksheet name to each of the worksheets.
In Print Preview you notice that the Expenses Summary sheet is not set to print correctly. Part of the chart is appearing on a second page. You can easily fix this by changing the Scaling, but you only want to change the scaling of the Expenses Summary sheet, not the entire workbook. If you make the change in Print Preview while the worksheets are grouped it will change all of the worksheets.
Key Takeaways
- To print all of the worksheets in a workbook at one time select Print Entire Workbook in the Print Settings.
- You can apply page setup options, such as scaling, orientation, and headers/footers, to multiple worksheets at one time by grouping the worksheets.
“6.4 Preparing to Print” by Julie Romey, Portland Community College is licensed under CC BY 4.0
Data file: PR6 Data
You have just gotten a job with the Pacific Northwest Soccer Club, and you quickly realize that there isn’t a consistent way for all the coaches to keep track of their team statistics. To help with this, you decide to make a template for Season Stats for each team. Since you are also the coach of the High Flyers this season, you will need to use the template to enter your team’s statistics into a team spreadsheet.
Played | Started | Shots | Goals | |
Game 1 | x | x | 2 | 1 |
Game 2 | x | x | 3 | 1 |
Game 3 | ||||
Game 4 | x | |||
Game 5 | x | x | 2 | 0 |
Game 6 | x | |||
Game 7 | ||||
Game 8 | x | x | 1 | 1 |
Game 9 | x | x | 4 | 2 |
Game 10 | x | x | 3 | 3 |
Played | Started | Shots | Goals | |
Game 1 | x | x | 1 | 1 |
Game 2 | x | x | 2 | 1 |
Game 3 | x | x | 1 | 1 |
Game 4 | x | x | 1 | 1 |
Game 5 | x | x | 2 | 0 |
Game 6 | x | x | 5 | 2 |
Game 7 | x | x | 4 | 2 |
Game 8 | x | x | 1 | 1 |
Game 9 | x | x | 4 | 1 |
Game 10 | x | x | 3 | 2 |
Played | Started | Shots | Goals | |
Game 1 | x | x | 0 | 0 |
Game 2 | x | x | 1 | 1 |
Game 3 | x | x | 2 | 0 |
Game 4 | x | 1 | 1 | |
Game 5 | x | x | 2 | 0 |
Game 6 | x | x | 3 | 1 |
Game 7 | x | x | 2 | 1 |
Game 8 | x | x | 1 | 1 |
Game 9 | x | x | 1 | 1 |
Game 10 | x | x | 1 | 1 |
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Data file: none
You are working in the National Headquarters of the National Parks Department. One of your jobs this week is to develop a template for individual park use data, along with a Summary of the parks visitation data. To do this you will need to create a template with summary and individual park sheets, and then use the template to enter park data for five national parks.
Table 4: 2015 National Park Data
Park | Recreation Visitors | Non-Recreation Visitors | Recreation Hours | Non-Recreation Hours | Concessioner Lodging | Concessioner Camping | Tent Campers | RV Campers | Backcountry Campers | Miscellaneous Overnight Stays | |
Acadia NP | 2,811,184 | 47,100 | 14,452,151 | 47,100 | 0 | 0 | 135,000 | 32,094 | 1,233 | 8,343 | |
Blue Ridge PKWY | 15,054,603 | 1,942,260 | 93,977,122 | 971,136 | 53,688 | 0 | 61,481 | 33,499 | 2,101 | 1,294 | |
Crater Lake NP | 614,712 | 49,600 | 4,033,484 | 24,800 | 34,629 | 55,596 | 7,548 | 0 | 3,253 | 0 | |
Yellowstone NP | 4,097,710 | 1,156,118 | 82,016,845 | 711,795 | 552,940 | 584,979 | 104,149 | 69,830 | 44,898 | 11,715 | |
Yosemite NP | 4,150,217 | 155,081 | 78,505,877 | 3,993,223 | 938,418 | 0 | 588,701 | 284,372 | 211,966 | 39,214 | |
National Park 2015 Data from: https://irma.nps.gov/Stats/SSRSReports
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